poj 3077 Rounders/bnuoj 3196 Rounders 解题报告

这道题我真的想说“呵呵”!为什么呢?不是因为它是水题,而是因为我在bnu上提交AC之后转而去poj(pku)上去提交,结果是CE!!!明明在bnu上有着“This problem will be judged on PKU. Original ID: 3077”这样的话,怎么想都不应该。没办法,只能看看哪里不对了。原来是pow()函数的问题。于是在pow的第一个参数前强制类型转换成(double)型,再去提交。终于AC了。

题目链接:

http://www.bnuoj.com/bnuoj/problem_show.php?pid=3196

http://poj.org/problem?id=3077

题目:

Rounders

Description

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on ...

Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Output

For each integer in the input, display the rounded integer on its own line. 

Note: Round up on fives.

Sample Input

9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output

20
10
4
5
100
10000000
50000000
2000
500
 
 
 
 

题意:

给n个数字,对于每个数字的每一位从右到左进行四舍五入操作,直到最高位的前一位,最高位仅考虑前一位的进位,不作四舍五入运算
解题思路:
1、从个位向高位一次判断(四舍五入)。
2、判断到最高为后输出结果
#include<iostream>
#include<iomanip>
#include<math.h>
using namespace std;

int main()
{
    int n, num, mod, cnt;
    cin >> n;
    for(int i = 0; i < n ; i ++)
    {
        cnt = 0;
        cin >> num;
        while(num!=0)
        {
            mod = num % 10;
            num = num / 10;
            //从个位向高位做四舍五入的判断
            if(mod >= 5 && mod <= 9 && num > 0)//个位>5则高位+1(5入操作)
            {
                num = num + 1;
            }
            else//(4舍操作)
            {
                num = num;
            }
            cnt ++;
        }
        cout.precision(0);
        cout << fixed << mod * pow((double)10, (int)cnt - 1) << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值