BNUOJ 15348 Fibonacci Numbers

该博客介绍了BNUOJ 15348题目的详细内容,即计算斐波那契数列的指定项。题目保证所求的斐波那契数不超过1000位。作者提供了两种解题思路,包括使用大数加法(涉及memcpy函数)以及利用Java的大数运算。
摘要由CSDN通过智能技术生成

题目链接:

http://www.bnuoj.com/bnuoj/problem_show.php?pid=15348

题目:

Fibonacci Numbers

A Fibonacci sequence is calculated by adding the previous two members of the sequence, with the first two members being both 1.

f(1) = 1, f(2) = 1, f(n > 2) = f(n - 1) + f(n - 2)

Your task is to take a number as input, and print that Fibonacci number.


Sample Input

100


Sample Output

354224848179261915075


Note:

No generated Fibonacci number in excess of 1000 digits will be in the test data, i.e. f(20) = 6765 has 4 digits.

题意:

求第n个斐波那契数列的值。

解题思路1:

1、大数加法(memcpy函数)

2、注意边界(边界的大小很重要,试了很久都不对,参考了一下别人的代码)

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 7000;
int f[MAX][2000];
int len[MAX];

int main()
{
    int n;
    memset(f, 0, sizeof(f));
    f[1][1] = 1;
    f[2][1] = 1;
    len[1] = 1;
    len[2] = 1;
    for(int i = 3; i <= MAX - 1; i ++)
    {
        memcpy(f[i], f[i - 1], sizeof(f[i - 1]));
        int maxlen = max(len[i - 2], len[i - 1]);

        for(int j = 1; j <= maxlen; j ++)
        {
            f[i][j] += f[i - 2][j];
        }

        for(int j = 1; j <= maxlen; j ++)
        {
            if(f[i][j] >= 10)
            {
                f[i][j + 1] += f[i][j] / 10;
                f[i][j] = f[i][j] % 10;

            }
        }

        if(f[i][maxlen] != 0)
        {
            maxlen ++;
        }

        len[i] = maxlen;
    }

    while(cin >> n)
    {
        for(int i = len[n] - 1; i > 0; i --)
        {
            cout << f[n][i];
        }
        cout << endl;

    }
    return 0;
}

解题思路2:

1、用java大数(一下子就水的不得了了)

import java.util.*;
import java.math.*;
public class Main
{
	public static void main(String args[])
	{
		int n;
		BigInteger f[] = new BigInteger[10000];
		Scanner in = new Scanner(System.in);  
        while(in.hasNextBigInteger())
        {
        	f[1] = BigInteger.ONE;
        	f[2] = BigInteger.ONE;
        	n = in.nextInt();
        	for(int i = 3; i <= n; i ++)
        	{
        		f[i] = f[i - 1].add(f[i - 2]);
        	}
        	System.out.println(f[n]);
        }
	}

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值