A + B Problem II

Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 

 

Sample Input

 

2 1 2 112233445566778899 998877665544332211

 

Sample Output

 

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

#include <bits/stdc++.h>
using namespace std;
char a[10000],b[10000];
char s[10000];
int main(){
	int t;
	scanf("%d",&t);
	for(int k=1;k<=t;k++){
	getchar();
	scanf("%s %s",a,b);
		int len1=strlen(a)-1;
		int len2=strlen(b)-1;
		int d=0;
		int c=0;
		while(len1>=0 || len2>=0){
			int w=0;
			if(len1>=0)
				w+=a[len1]-'0';
			if(len2>=0)
				w+=b[len2]-'0';
			w+=c;
			s[d]=w%10+'0';
			c=w/10;
			d++;
			len1--;
			len2--;
		}
		while(c){
			s[d++]=c%10+'0';
			c/=10;
		}
		printf("Case %d:\n",k);
		printf("%s + %s = ",a,b);
		for(int i=d-1;i>=0;i--)//倒序输出 
			printf("%c",s[i]);
		printf("\n");
		if(k!=t)
		printf("\n");
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值