Time Zone

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s .

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106 ), indicating the number of test cases. For each test case:
The first line contains two integers a , b (0≤a≤23,0≤b≤59 ) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9 ).

 

 

Output

For each test, output the time in the format of hh:mm (24-hour clock).

 

 

Sample Input

 

3 11 11 UTC+8 11 12 UTC+9 11 23 UTC+0

 

 

Sample Output

 

11:11 12:12 03:23

 

 

Source

2018 Multi-University Training Contest 1

 

 

Recommend

liuyiding

#include <iostream>
#include <string.h>
using namespace std;
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int h,m,d=0;
		int s=0;
		char c[10];
		scanf("%d %d %s",&h,&m,c);
		int w=4;
		int f=0;
		int len=strlen(c);
		while(c[w]>='0' && c[w]<='9' && w<len){
			s=s*10+c[w]-'0';
			w++;
		}
		if(c[3]=='-'){
			f=1;
		}
		if(c[w]=='.'){
			w++;
			while(c[w]>='0' && c[w]<='9' && w<len){
				d=d*10+c[w]-'0';
				w++;
			}
		}
		if(f==1){
			if(d!=0){
				d=10-d;
				s=16-s;
				s--;
				h=(24+s+h)%24;
				if(h==-1)
					h==23;
			}
			else{
				s=16-s;
				h=(24+s+h)%24;
			}
		}
		else{
			h=(24+(s-8)+h)%24;
		}
		m+=6*d;
		if(m>=60){
			m-=60;
			h++;
			h=h%24;
		}
		printf("%02d:%02d\n",h,m);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值