Triangle Partition

Problem Description

Chiaki has 3n points p1,p2,…,p3n . It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

 

Input

There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000 ) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109 ).
It is guaranteed that the sum of all n does not exceed 10000 .

 

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n ) each denoting the indices of points the i -th triangle use. If there are multiple solutions, you can output any of them.

 

 

Sample Input

 

1 1 1 2 2 3 3 5

 

 

Sample Output

 

1 2 3

 

 

Source

2018 Multi-University Training Contest 1

因为不可能三点共线,所以直接排序输出

#include <bits/stdc++.h>
using namespace std;
struct haha{
	int x,y;
	int s;
}we[300000];
bool cmp(haha a,haha b){
	if(a.x==b.x) return a.y<b.y;
	return a.x<b.x;
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n;
		scanf("%d",&n);
		n=n*3;
		for(int i=0;i<n;i++){
			scanf("%d %d",&we[i].x,&we[i].y);
			we[i].s=i;
		}
		sort(we,we+n,cmp);
		for(int i=0;i<=n-3;i+=3){
			printf("%d %d %d\n",we[i].s+1,we[i+1].s+1,we[i+2].s+1);
		}
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值