HDU1081 - To The Max - 状态压缩DP【经典】

1.题目描述:

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12543    Accepted Submission(s): 6018


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1080  1074  1059  1158  1224 
 
2.题意概述:

给你一矩阵,定义矩阵的和为其所有子元素的和,求包括本身的所有子矩阵的和的最大值

3.解题思路:

暴力枚举肯定会T,因为问题不具有后效性,考虑动态规划,先预处理一下mp[i][j]表示第i行前j列元素的和,把多维转化为一维的,那么每次枚举i,j,求它们的最大连续子序列和就行,需要注意的是子元素可能有负,因此ans要设为-INF(实思路挺巧的,是一道很经典的好题)

4.AC代码:

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define maxn 100100
#define N 155
#define eps 1e-6
#define pi acos(-1.0)
#define e 2.718281828459
#define mod (int)1e9 + 7
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
int dp[N][N];
int main()
{
#ifndef ONLINE_JUDGE
  freopen("in.txt", "r", stdin);
  freopen("out.txt", "w", stdout);
  long _begin_time = clock();
#endif
  int n;
  while (~scanf("%d", &n))
  {
    memset(dp, 0, sizeof(dp));
    for (int i = 1; i <= n; i++)
      for (int j = 1; j <= n; j++)
      {
        int x;
        scanf("%d", &x);
        dp[i][j] += dp[i][j - 1] + x;
      }
    int ans = -INF;
    for (int i = 1; i <= n; i++)
      for (int j = i; j <= n; j++)
      {
        int sum = 0;
        for (int k = 1; k <= n; k++)
        {
          if (sum < 0)
            sum = 0;
          sum += dp[k][j] - dp[k][i - 1];
          ans = max(ans, sum);
        }
      }
    printf("%d\n", ans);
  }

#ifndef ONLINE_JUDGE
  long _end_time = clock();
  printf("time = %ld ms.", _end_time - _begin_time);
#endif
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值