基于Packet Tracer的校园网络设计与规划

本文仅仅为本人课程要求而设计的方案,本文仅仅使用RIP动态路由协议,HSRP协议,浮动路由,静态路由,等价路由,DHCP地址分配,NAT技术,VLAN划分。如有问题请大佬们在本博客下留言。课程设计报告文件,资源链接:Packet Tracer 文件https://download.csdn.net/download/dragon_18/10902464。 实验报告文档 https://download.csdn.net/download/dragon_18/10902448

一、设计要求

模拟设计并实现校园网规划,完成拓扑结构设计、IP 地址规划、路由协议、网络管理规划、安全管理规划,用软件模拟器实现此规划。选取设备和协议根据你对校园网的了解和调研情况确定,也可以进行适当程度的假设。

二、分析

我们将校园网设计为三个层级:接入层、汇聚层、核心层。这样规划能够有良好的层次感,利于实现复杂的网络功能要求,并且可以使每层的功能容易实现也较清楚。采用这样的分层方式可以支持较大的网络规模便于日后的网络升级与扩大。在校园网设有学生管理系统的服务器,并实现校园内网与互联网的访问。
在进行网络拓扑设计时,按照处于位置不同的原则。在每个不同的楼层或组织设置了一个接入层交换机,实现终端用户连接到网络,因此接入层交换机需具有低成本和高密度的特性。
在每个学院设置一个楼宇交换机作为汇聚层设备,实现工作组的接入,广播域的定义,VLAN分割。并且可以实现处理来自接入层设备的所有通信量,并提供到核心层的上行链路的特点。划分VLAN可以隔离广播风暴,极大程度上保障网络的可靠性。
在校园网的网络管理中心,设有核心层设备。目的是尽可能快的交换数据包,构成高速的交换骨干。因此我们选用三层交换机作为核心层设备。并采用出口路由冗余负载均衡线路设计。
为了解决IP地址短缺的问题并为了校园网络日后的升级与扩容,我们进行了IP地址规划。在校园网内的主机(除服务器)规划为192.168.x.x的地址格式。在极大可能在未来需要扩容的地方规划主机容量为255,在扩容小的地方采用主机容量为7的子网掩码。并在出口路由上设置了NAT协议。
校园网可以看做一个小型局域网,因此我们采用了rip路由协议进行动态路由汇总。此协议的优点为rip简单并且使用的是UDP数据报进行通信,占用资源少,传输快。
作为一个局域网内部的主机不可以被Internet上的主机随意访问,因此采用了在出口路由上设置NAT网络地址转换协议的方式实现屏蔽内网的作用。极大的提高了内网的安全性。
作为互联互通的网络,校园网不能与外界网络隔离开来。因此,我们在核心层上连接了一个出口路由器。并且在此路由器上可以设置NAT协议达到安全管理的规划。

三、设计

接入层是为了用户可以直接使用的校园网, 能够对所使用的网络进行逻辑隔离, 也负责整个系统的稳定性和安全性。根据信息学院分为两层一个学生组织(如下表所示),学生组织一层和二层各设有办公室。所以我们根据信息学院的特点将两个二层交换机作为接入层设备,在两个交换机上各划分为两个VLAN。在两个交换机之间利用trunk技术将学生会的办公室划分为同一个VLAN。在外语学院,(如下表所示)我们以组织作为一个整体划分为同一个VLAN。因此我们将每个楼层设有的交换机利采用runk技术使其相连。考虑到外语学院用户流量不是十分大,所以将一层交换机利用trunk技术与汇聚层相连。
考虑到各个学院要进行设备的扩容,我们将每层或组织的终端主机号容量规划为255个。根据即插即用自动分配IP地址的原则在接入层下设置了一个次级二层交换机。在此二层交换机上连接的终端主机直接划分此VLAN的IP地址。达到即插即用自动为终端主机分配IP地址的目的。
名称 VLAN IP网络号 主机容量 接口
信息学院一层 10 192.168.1.0/24 255 Sw1 f0/1-2
Sw0 f0/0-24
信息学院学生会 20 192.168.2.0/24 255 Sw1 f0/3
Sw2 f0/2
信息学院二层 30 192.168.3.0/24 255 Sw1 f0/6
Sw3 f0/0-24
外语学院协会 40 192.168.4.0/24 255 Sw4 f0/1
Sw5 f0/2
外语学会学生会 50 192.168.5.0/24 255 Sw4 f0/1
Sw5 f0/2

汇聚层可以实现工作组的接入,广播域的定义,VLAN分割。并且必须具有处理来自接入层设备的所有通信量,并提供到核心层的上行链路的特点。汇聚层设备一般采用可管理的三层交换机或堆叠式交换机以达到带宽和传输性能的要求。在此次设计中,我们选用的是可管理的三层交换机作为汇聚层设备。
在学校的每个学院楼设备间放置一台汇聚交换机,此交换机是一栋楼的汇聚点,用来转发本区域用户到其他区域用户的横向流量,同时将本区域用户流量发送到核心层。汇聚层将大量用户接入到互联的网络中,模块化扩展接入核心层设备的用户数量。汇聚层具有高转发性能、高端口密度、高带宽等特点,用于支撑该汇聚层下各业务部门之间的流量。 根据本设计中学校对网络的需求我们选用了思科3560交换机。实现本楼内各个VLAN间的通信和将数据上传至核心层的作用。
在信息楼汇聚交换机和外语楼汇聚交换机设置虚接口并设置各个VLAN的IP地址。启用路由功能来实现各个VLAN间的通信。并在汇聚层交换机上设置DHCP服务。因为校园网的用户使用量非常巨大, 并且学生用IP地址存在流动性, 因此人工分发IP地址显然难以实现, 因此需要借助DHCP动态分配IP技术, 这样就完美解决了IP地址分发的问题。
为了提升网络的性能,汇聚层到核心层间采用RIP动态路由协议进行路由层面的高可用保障。因为校园网在其规模上不能称为大型网络,因此选用RIP路由协议实现路由信息的动态传播,达到楼宇间的通信。
核心层是一个高速的交换式骨干。他的设计目标是使得交换分组所耗费的时间演示最小。园区网的这一层不应该对数据包帧进行任何的处理,比如处理访问列表和进行过滤,因为这会降低包交换的速度。目前常见的做法是在核心层完全采用第3层交换环境,这就意味着VLAN和VLAN trunks不会出现在核心层中。这也意味着在核心层中生成树环路通常也可以避免。核心层的主要功能是在园区网的各个汇聚层设备之间提供高速的连接。核心层要处理大量的数据汇总和转发,所以核心层应使用冗余和负载均衡设计。
根据以上原则,我们选用思科的3560交换机作为核心交换机。此交换机连接有各个楼宇汇聚层交换机、出口路由器和服务器。考虑线路负载均衡及冗余时,我们使用等价路由的方式使核心交换机与出口网关通过两个线路相连接。在此次规划中核心层设备连接的设备并没有超过十台,所以我们采用构造超网的方法分配各个网段的IP地址。IP地址分配如下表所示:
端口 网络号 端口IP地址 备注
F0/1 192.168.6.0/29 192.168.6.1 连接信息楼
F0/3 192.168.6.8/29 192.168.6.9 连接外语楼
F0/22 192.168.6.24/29 192.168.6.25 连接内网服务器
F0/2 192.168.6.16/29 192.168.6.17 连接出口路由器
F0/23 192.168.6.32/29 192.168.6.33 连接出口服务器
局域网的出口网关,可以用来隔离广播风暴;可以连接不同局域网互通,局域网域互联网的互通,实现不同的网路互通,现在大多数企业都是用路由器来做分支机构的互联互通
网络管理功能;可以通过路由策略,对网络访问做控制,通过路由策略,可以有效的管理访问权限和保护网络安全。有效抵御网络攻击。
此次设计,选用思科的2911路由器作为出口网关。利用地址转换协议(nat)解决了运营商分配IPv4地址短缺的问题,并且将校园内部网络与互联网相隔离保障内部主机的安全。为了保障校园网出口的稳定性,我们设置浮动路由来连接到两个不同的ISP。此浮动路由是网络的默认路由。并通过rip动态路由协议将静态默认路由分发到核心层和汇聚层。
校园网采用双出口的方式提高网络的稳定性。我们布置了两个路由器一个交换机和一个服务器来模拟ISP网络 。为了测试双出口的可用性我们在ISP的路由器之间利用路由器热备份协议(HSRP)来实现各个路径的可用性。

整体设计图

四、实现

接入层实现
Switch1实现VLAN划分、VLAN内通信
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface range f0/1-2
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#exit
Switch(config)#interface f0/3
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface f0/6
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#interface f0/7
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

Switch2实现VLAN划分、VLAN内通信
Switch(config)#vlan 30
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface range f0/3-6
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#exit
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface f0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

Switch4实现VLAN划分、VLAN内通信
Switch(config)#vlan 40
Switch(config-vlan)#exit
Switch(config)#vlan 50
Switch(config-vlan)#exit
Switch(config)#interface f0/1
Switch(config-if)#switchport access vlan 40
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 50
Switch(config-if)#exit
Switch(config)#interface range f0/5-6
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#exit

Switch5实现VLAN划分、VLAN内通信
Switch(config)#vlan 40
Switch(config-vlan)#exit
Switch(config)#vlan 50
Switch(config-vlan)#exit
Switch(config)#interface f0/1
Switch(config-if)#switchport access vlan 40
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 50
Switch(config-if)#exit
Switch(config)#interface f0/5
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

4.2汇聚层实现
Multilayer Switch0实现VLAN间通信及开启DHCP服务
Switch(config)# vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#exit
Switch(config)#interface VLAN10
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface VLAN20
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface VLAN30
Switch(config-if)#ip address 192.168.3.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip routing
Switch(config)#interface f0/4
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.6.2 255.255.255.248
Switch(config-if)#exit
Switch(config)#ip dhcp pool vlan10
Switch(dhcp-config)#network 192.168.1.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.1.1
Switch(dhcp-config)#exit
Switch(config)#ip dhcp pool vlan20
Switch(dhcp-config)#network 192.168.2.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.2.1
Switch(dhcp-config)#exit
Switch(config)#ip dhcp pool vlan30
Switch(dhcp-config)#network 192.168.3.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.3.1
Switch(dhcp-config)#exit

Multilayer Switch3实现VLAN间通信及开启DHCP服务
Switch(config)# vlan 40
Switch(config-vlan)#exit
Switch(config)#vlan 50
Switch(config-vlan)#exit
Switch(config)#interface VLAN40
Switch(config-if)#ip address 192.168.4.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface VLAN50
Switch(config-if)#ip address 192.168.5.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip routing
Switch(config)#interface f0/3
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.6.18 255.255.255.248
Switch(config-if)#exit
Switch(config)#ip dhcp pool vlan40
Switch(dhcp-config)#network 192.168.4.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.4.1
Switch(dhcp-config)#exit
Switch(config)#ip dhcp pool vlan50
Switch(dhcp-config)#network 192.168.5.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.5.1
Switch(dhcp-config)#exit

4.3核心层实现

Multilayer Switch1实现楼宇间通信及上交数据
Switch(config)#interface f0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.6.1 255.255.255.248
Switch(config-if)#exit
Switch(config)#interface f0/2
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.6.9 255.255.255.248
Switch(config-if)#exit
Switch(config)#interface f0/3
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.6.17 255.255.255.248
Switch(config-if)#exit
Switch(config)#interface f0/22
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.6.25 255.255.255.248
Switch(config-if)#exit
Switch(config)#interface f0/23
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.6.33 255.255.255.248
Switch(config-if)#exit
Switch(config)#interface f0/24
Switch(config-if)#no switchport
Switch(config-if)#ip address 202.206.65.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip routing
Switch(config)#ip route 0.0.0.0 0.0.0.0 f0/23
Switch(config)#ip route 0.0.0.0 0.0.0.0 f0/2
Switch(config)#route rip
Switch(config-router)#network 192.168.6.0
Switch(config-router)#network 192.168.6.8
Switch(config-router)#network 192.168.6.16
Switch(config-router)#network 192.168.6.24
Switch(config-router)#version 2
Switch(config-router)#no auto-summary

4.4 出口网关设置

Router1配置rip协议、多出口冗余和地址转换实现访问互联网的功能
Router(config)#ip route 0.0.0.0 0.0.0.0 202.206.64.30
Router(config)#ip route 0.0.0.0 0.0.0.0 202.206.66.30 10
Router(config)#access-list 1 permit 192.168.0.0 0.0.255.255
Router(config)#ip nat inside source list 1 pool poolRoute
Router(config)#interface s0/0/0
Router(config-if)#ip address 202.206.64.20 255.255.255.0
Router(config-if)#ip nat outside
Router(config-if)#no shutdown
Route(config-if)#exit
Router(config)#interface s0/0/1
Router(config-if)#ip address 202.206.66.20 255.255.255.0
Router(config-if)#ip nat outside
Router(config-if)#no shutdown
Route(config-if)#exit
Router(config)#interface f0/0
Router(config-if)#ip address 192.168.6.10 255.255.255.248
Router(config-if)#ip nat inside
Router(config-if)#no shutdown
Route(config-if)#exit
Router(config)#interface f0/1
Router(config-if)#ip address 202.206.65.1 255.255.255.0
Router(config-if)#no shutdown
Route(config-if)#exit
Router(config)#route rip
Router(config-router)#network 192.168.6.8
Router(config-router)#network 202.206.65.0
Router(config-router)#version 2
Router(config-router)#no auto-summary
Router(config-router)# default-information originate
Router(config-router)#exit

展开阅读全文

没有更多推荐了,返回首页