Prime Path 素数路径

问题描述

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033
1733
3733
3739
3779
8779
8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3

1033 8179

1373 8017

1033 1033

Sample Output

6

7

0

思路

本题是将两个素数之间的所有素数找出来,但是前提是以当前素数为主,每次只能改变一位数字,同时要求变换的次数尽可能少。我们可以利用BFS算法来进行广度搜索。可以利用埃式筛法将小于四位数的素数筛选出来,再进行BFS搜索,BFS一般利用队列实现,将起始点入队,通过for循环,依次遍历个位(个位直接按照质数查找,因为素质的个位必定是质数),十位,百位,千位(1-9)的数字,一旦有符合素数条件的,就入队。当所有位数都查找完后,此数字出队,再按照下一个数字进行按位遍历,以此类推,直到队列为空。

代码

#include<cstdio>
#include<queue>
#include<cstring> 
using namespace std;

typedef struct PrimePath{
    int number;
    int step;
} PrimePath;

bool is_prime[10001];

void sieve()//筛子,筛选素数
{
    for(int i=2;i<=9999;++i){
        is_prime[i] = true;
    }
    for(int i=2;i<=9999;++i){//埃式筛法
        if(is_prime[i]){
            for(int j=2;i*j<=9999;++j){
                is_prime[i*j] = false;//所有不是素数都为flase 
            }
        }
    }
}

void bfs(int start_prime, int end_prime)//广度搜索
{
    queue<PrimePath> que;//建立一个队列 
    bool visited[10001] = {false};//标记访问数组 
    PrimePath start = {start_prime, 0};//初始化一个开始路径 
    que.push(start);//进队列 
    visited[start_prime] = true;//此访问数组有效,设为true 
    while(!que.empty()){
        PrimePath curPrime = que.front();//队头元素赋值给一个结构体对象 
        que.pop();//出队列 
        if(curPrime.number == end_prime){//如果此数与终点数相同,打印花费 
            printf("%d\n", curPrime.step);
            return;
        }
        for(int i=1;i<=9;i+=2){				//通过选取数字最后一位的取值,判断此数字是不是素数,如果是并且没有被访问过,那么构造此数字的结构体(step要+1),进队列 
            int num = curPrime.number / 10 * 10 + i;
            if(is_prime[num] && !visited[num]){
                PrimePath n = {num, curPrime.step+1};//验证成功,构造结构体 
                que.push(n);//入队列 
                visited[num] = true;//此数字已被正确访问 
            }
        }
        for(int i=0;i<=9;i++){  //循环遍历倒数第二位,从0-9 
            int num = curPrime.number / 100 *100 + i*10 + curPrime.number%10;
            if(is_prime[num] && !visited[num]){
                PrimePath n = {num, curPrime.step+1};
                que.push(n);
                visited[num] = true;
            }
        }
        for(int i=0;i<=9;i++){//循环遍历倒数第三位,从0-9 
            int num = curPrime.number / 1000 *1000 + i*100 + curPrime.number%100;
            if(is_prime[num] && !visited[num]){
                PrimePath n = {num, curPrime.step+1};
                que.push(n);
                visited[num] = true;
            }
        }
        for(int i=1;i<=9;i++){//循环遍历第一位,从1-9 
            int num = i*1000 + curPrime.number%1000;
            if(is_prime[num] && !visited[num]){
                PrimePath n = {num, curPrime.step+1};
                que.push(n);
                visited[num] = true;
            }
        }
    }
}

int main()
{
    int t;
    int start_prime, end_prime;
    sieve();
    scanf("%d", &t);
    while(t--){
        scanf("%d %d", &start_prime, &end_prime);
        bfs(start_prime, end_prime);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值