Bored Three-God

J - Bored Three-God

  NBUT - 1228 


The bored Three-God get another boring question. 

This problem is ask you plus two big nubmer, please help him, when you solve this problem you can

speak to Three-God,"Oh, Please give me a diffculte one, this one is too easy".

Input
There are muti-case 
For each case, there are two integers, n, m (0 < n, m < 10^10000).
Output
Calculate two integers' sum
Sample Input
1 1
2 3
10000 100000
Sample Output
2
5
110000
Hint


题意 :大数A+B 这题有个很坑的点就是输出前导零 列如 005 006    输出 011    


#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#include<map>
#include<queue>
#include<math.h>
#include<queue>
#include <deque>
#include <cstdio>
#include<list>
#define LL long long
using namespace std;
char a[1001000];
char b[1001000];
int a1[1001000];
int b1[1001000];
int c[1001000];
int main()
{
   while(~scanf("%s%s",a,b))
   {
     memset(a1,0,sizeof(a1));
       memset(b1,0,sizeof(b1));
       memset(c,0,sizeof(c));
     int k1=strlen(a);
     int k2=strlen(b);
    for(int i=0;i<k1;i++)
     {
         a1[i]=a[k1-1-i]-'0';
     }
     for(int i=0;i<k2;i++)
     {
         b1[i]=b[k2-1-i]-'0';
     }
     int k=max(k1,k2);
     int d=0;
     for(int i=0;i<=k;i++)
     {
         int t=a1[i]+b1[i]+d;
         c[i]=t%10;
         d=t/10;
     }
//          int l=-1;
//     for(int i=k;i>=0;i--)
//     {
//         if(c[i]!=0)
//         {
//             l=i;
//             break;
//         }
//     }
        if(c[k]!=0)
        printf("%d",c[k]);
      for(int i=k-1;i>=0;i--)
     {
         printf("%d",c[i]);
     }
     printf("\n");
   }
}







 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值