acm Trailing Zeroes (III)


  

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible


N!末尾0的求法//其中代码可能溢出,不如用除法= =

参考//注意到了右边界的范围= =天,一直WA,不知道为什么

试了一遍int和longlong都能过= =

#include<cstdio>
#include<algorithm>
using namespace std;
long long ze(long long n)//n!末尾0的个数 
{
long long num=0;
	while(n){
		num+=n/5;
		n/=5; 
	}
	return num;
}
int main()
{
	long long m,q,ans,t=1;
	scanf("%lld",&m);
	while(m--)
	{
		scanf("%lld",&q);
		long long l=0,r=400000016;//r的范围<=5*10^8 = =之前范围小了,一直WA 
		while(l<=r)
		{
			long long  mid=(l+r)/2;
			if(ze(mid)>=q){//0的个数大于q,则向左
			r=mid-1;
		    ans=mid;
			}
			  else 
			     l=mid+1;
		}
		if(ze(ans)==q)
	     printf("Case %lld: %lld\n",t++,ans) ;
		else
		 printf("Case %lld: impossible\n",t++);
	
	}return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值