PAT-1072 Gas Station

 

1072 Gas Station(30 分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

    题目要求找出距离居住区最小距离中距离最大的一个候选点,若不唯一,选距离所有居住区平均距离小的,还不唯一,选序号小的。注意如果使用Floyd算法是O(\LARGE N^{3})的复杂度,题目中顶点数约为1000,容易超时(pat最后一个测试用例过不了)。最好是对M个候选点使用Dijkstra算法,不会超时。

#include<stdio.h>
#include<string>
#include<sstream>
#include<algorithm>
using namespace std;
#define INF 0x3fffff

int g[1020][1020];
int d[15];//距离居住区最近距离
int sum[15];//距离居住区距离和
int N,M,K,dmax;
void dijkstra(int n){
	int dis[1020];bool visited[1020];
	fill(dis,dis+1020,INF);
	fill(visited,visited+1020,false);
	dis[n]=0;
	while(1){
		int t=-1;int mindis=INF;
		for(int i=1;i<=N+M;i++){
			if(!visited[i]&&dis[i]<mindis){
				mindis=dis[i];
				t=i;
			}
		}
		if(t==-1)
			break;
		visited[t]=1;
		for(int i=1;i<=N+M;i++){
			if(!visited[i]&&g[i][t]!=INF&&dis[i]>dis[t]+g[i][t]){
				dis[i]=dis[t]+g[i][t];
			}
		}
	}
	int mindis=INF,sumdis=0;
	for(int i=1;i<=N;i++){
		if(dis[i]>dmax){
			mindis=INF;
			sumdis=INF;
			break;
		}
		sumdis+=dis[i];
		if(dis[i]<mindis){
			mindis=dis[i];
		}
	}

	d[n-N]=mindis;
	sum[n-N]=sumdis;

}
int getindex(char *p){
	int index=0;

	if(p[0]=='G'){
		string st(p+1);
		stringstream stream(st);
		stream>>index;
		index+=N;
	}else{
		string st(p);
		stringstream stream(st);
		stream>>index;
	}
	return index;
}
int main(){
	scanf("%d %d %d %d",&N,&M,&K,&dmax);

	fill(g[0],g[1019]+1020,INF);
	char p1[10],p2[10];int ip1,ip2,dis;
	for(int i=0;i<K;i++){
		scanf("%s %s %d",p1,p2,&dis);
		ip1=getindex(p1);
		ip2=getindex(p2);
		g[ip1][ip2]=dis;
		g[ip2][ip1]=dis;
	}

	for(int k=1;k<=M;k++){
		dijkstra(k+N);
	}
	int ans=-1,maxmin=0,summin=INF;
	for(int i=1;i<=M;i++){
		if(d[i]==INF)
			continue;
		if(d[i]>maxmin||(d[i]==maxmin&&sum[i]<summin)){
			maxmin=d[i];ans=i;summin=sum[i];
		}
	}

	if(ans==-1)
		printf("No Solution");
	else{
		printf("G%d\n",ans);
		printf("%.1f %.1f",maxmin*1.0,summin*1.0/N);
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值