PAT-1105 Spiral Matrix

1105 Spiral Matrix(25 分)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and nsatisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

    回旋的矩阵,难点就在正确找到一圈一圈路径,一圈分为四部分分别处理,注意中间只剩一块时能否访问到。

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;

int a[10005]={0};
int mn[505][505];
int main(){
	int N;
	scanf("%d",&N);
	for(int i=0;i<N;i++){
		scanf("%d",a+i);
	}
	int m,n;
	for(int i=sqrt(1.0*N);i>0;i--){
		if(N%i==0){
			n=i;m=N/i;break;
		}
	}
	sort(a,a+N);
	int k=N-1,g=0;
	while(k>=0){
		for(int j=g;j<n-g&&k>=0;j++){
			mn[g][j]=a[k--];
		}
		for(int i=g+1;i<m-g-1&&k>=0;i++){
			mn[i][n-g-1]=a[k--];
		}
		for(int j=n-g-1;j>=g&&k>=0;j--){
			mn[m-g-1][j]=a[k--];
		}
		for(int i=m-g-2;i>g&&k>=0;i--){
			mn[i][g]=a[k--];
		}
		g++;
	}

	for(int i=0;i<m;i++){
		for(int j=0;j<n;j++){
			printf("%d",mn[i][j]);
			if(j!=n-1)printf(" ");
			else printf("\n");
		}
	}

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值