山东省第七届ACM大学生程序设计竞赛 字符串倒置

Reversed Word
Time Limit: 1000 MSMemory Limit: 131072 K

Description

Some aliens are learning English. They have a very strange way in writing that they revered every word in the sentence but keep all the words in common order. For example when they want to write “one two three”, they will write down “eno owt eerht”.

Now we’ve got some sentence written by these aliens, translate them! And maybe we will know some of their secrets!

Input

Multiple test cases. The first line contains a positive integer T (T <= 1000), indicates the number of test cases.

For each test cases, there will be one line contains only lower case letters and spaces. The length of each line will be no more than 10000. Test cases which are longer than 5000 will be less than 50. Continuous letters are seen as a word, words are separated by spaces. There won’t be two adjacent spaces in the input. Space won’t be the first or the last character.

Output
One line per case, the translated sentence.
Sample Input

2

eno owt eerht

abcde


Sample Output

one two three

edcba



看示例即可知道题目的意思。




#include<stdio.h>
#include<string.h>


int main()
{
char a[10005];
int i,j,k,t,len;

while(scanf("%d",&t)!=EOF)
{
getchar();  //接收回车 
while(t--)

gets(a);

len=strlen(a);   //长度 
for(i=0;i<len;)
       {
           if(a[i]==' ')    //如果遇到空格,输出 
printf("%c",a[i++]); //输出空格,i自加 

           else 
           {
               while(a[i]!= ' '&&i<len) //数组中是字符,且长度小于len 
i++;     //后移,碰到下一个空格或到最尾端 

               for(j=i-1;j>=0;j--)    //上面执行了i++,所以此处j要接收i-1的值 
               {
                   if(a[j] ==' ')    //遇到前面那个空格,输出结束 
break;

                   printf("%c",a[j]);   //倒序输出 
               }
           }
       }
       printf("\n");
}
}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值