What Are You Talking About

5 篇文章 0 订阅
3 篇文章 0 订阅
What Are You Talking About
Time Limit:5000MS     Memory Limit:204800KB     64bit IO Format:%I64d & %I64u
 
Practice
 
HDU 1075
Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him? 
Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters. 
Output
In this problem, you have to output the translation of the history book. 
Sample Input
START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END
Sample Output
hello, i'm from mars.
i like earth!

题目大意:将给出的火星文字符串翻译成英文字符串,每个单词有对应的英文单词,如果不存在对应的就输出原有的即可。

//AC...强大的STL
#include<map>
#include<cstdio>
#include<cctype>	//这个头文件不写也行,刚开始不知道为什么,明明用了islower函数,难道说#include<string>里包含的也有?下面有测试
#include<iostream>
#include<string>
using namespace std;
int main()
{
    string s,s1,s2,s3;
    map<string,string> m;
    cin>>s;
    while (cin>>s1)
    {
        if (s1.compare("END")==0)
            break;
        cin>>s2;
        m[s2]=s1;
    }
    getchar();
    while (getline(cin,s))
    {
        if (s.compare("START")==0)
            continue;
        if (s.compare("END")==0)
            break;
        for (int i=0;s[i]!=0;i++)
        {
            if (islower(s[i]))
                s3+=s[i];
            else
            {
                if (m.count(s3))
                    cout<<m[s3];
                else
                    cout<<s3;
                cout<<s[i];
                s3="";
            }
        }
        cout<<endl;
    }
    return 0;
}
关于islower函数头文件测试:

#include<stdio.h>
//#include<string.h>  //失败
#include<string>  //成功
//#include<ctype.h> //成功

int main()
{
    char str[20]="ABCqwerdf";
    int num=0;
    for (int i=0;str[i]!=0;i++)
        if (islower(str[i]))
            num++;
    printf("%d\n",num);
    return 0;
}
结论:#include<string>和#include<ctype.h>中都包含islower函数,而#include<string.h>中没有islower函数。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值