POJ-2528-Mayor's posters(线段树)

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source


思路:先离散化一下,把区间

1 10
1 3
6 10

处理成

1 7
1 3
5 7

再用线段树维护每个区间的颜色值,每个海报对应一种不同的颜色值。

注意:离散化的时候要分相邻和不相邻的情况。详见以下样例:

3
3
5 6
4 5
6 8
3
1 10
1 3
6 10
5
1 4
2 6
8 10
3 4
7 10

答案是:

2

3

4


源码:

#include <cstdio>
#include <algorithm>
using namespace std;

struct{
int l,r;
}q[10000];

struct H{        //用于离散化,id表示在原来的哪个海报,pos为0表示海报中的l,为1表示海报中的r
int val,id,pos;
}h[20000];

int color[160000];
bool vis[10001];

bool cmp(struct H a,struct H b)
{
    return a.val<b.val;
}

void build(int idx,int s,int e)
{
    if(s!=e)
    {
        int mid=(s+e)>>1;

        build(idx<<1,s,mid);
        build(idx<<1|1,mid+1,e);
    }

    color[idx]=0;//所有节点的颜色值初始化为0
}

void add(int idx,int s,int e,int l,int r,int val)
{
    if(s==l && e==r)//如果区间相同则直接更改颜色值
    {
        color[idx]=val;

        return;
    }

    if(color[idx] && color[idx]!=val)//如果有颜色并且颜色值不同则把颜色值赋给儿子节点并且将自己置零
    {
        color[idx<<1]=color[idx];
        color[idx<<1|1]=color[idx];

        color[idx]=0;
    }

    int mid=(s+e)>>1;

    if(r<=mid) add(idx<<1,s,mid,l,r,val);//在儿子
    else if(l>mid) add(idx<<1|1,mid+1,e,l,r,val);//在右儿子
    else//两边都有
    {
        add(idx<<1,s,mid,l,mid,val);
        add(idx<<1|1,mid+1,e,mid+1,r,val);
    }
}

int query(int idx,int s,int e)
{
    if(color[idx])
    {
        if(!vis[color[idx]])
        {
            vis[color[idx]]=1;

            return 1;
        }

        return 0;
    }

    if(s==e) return 0;

    int mid=(s+e)>>1;

    return query(idx<<1,s,mid)+query(idx<<1|1,mid+1,e);
}

int main()
{
    int T,n,i,last,total;

    scanf("%d",&T);

    while(T--)
    {
        scanf("%d",&n);

        for(i=0;i<n;i++)
        {
            scanf("%d%d",&q[i].l,&q[i].r);

            h[i*2].val=q[i].l;
            h[i*2].id=i;
            h[i*2].pos=0;

            h[i*2+1].val=q[i].r;
            h[i*2+1].id=i;
            h[i*2+1].pos=1;
        }

        //离散化
        sort(h,h+n*2,cmp);

        last=-1;
        total=0;

        for(i=0;i<n*2;i++)
        {
            if(h[i].val!=last)
            {
                if(h[i].val-last==1 || !total) total++;//注意区分相邻和不相邻的情况,虽然之前没判断也AC了,不过那是不对的
                else total+=2;

                if(h[i].val!=total)
                {
                    if(h[i].pos) q[h[i].id].r=total;
                    else q[h[i].id].l=total;
                }

                last=h[i].val;
            }
            else
            {
                if(h[i].val!=total)
                {
                    if(h[i].pos) q[h[i].id].r=total;
                    else q[h[i].id].l=total;
                }
            }
        }
        //离散化完成

        for(i=1;i<=n;i++) vis[i]=0;

        build(1,1,total);

        for(i=0;i<n;i++) add(1,1,total,q[i].l,q[i].r,i+1);
        
        printf("%d\n",query(1,1,total));
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值