POJ-2892-Tunnel Warfare(线段树)

Description

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately!

Input

The first line of the input contains two positive integers n and m (nm  50,000) indicating the number of villages and events. Each of the next m lines describes an event.

There are three different events described in different format shown below:

  1. D x: The x-th village was destroyed.
  2. Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.
  3. R: The village destroyed last was rebuilt.

Output

Output the answer to each of the Army commanders request in order on a separate line.

Sample Input

7 9
D 3
D 6
D 5
Q 4
Q 5
R
Q 4
R
Q 4

Sample Output

1
0
2
4

Hint

An illustration of the sample input:

      OOOOOOO

D 3   OOXOOOO

D 6   OOXOOXO

D 5   OOXOXXO

R     OOXOOXO

R     OOXOOOO

Source


思路:线段树维护每个区间的左右两端分别到中间的最大连续区间的大小,注意左右子树可能存在最大连续区间大小就等于该节点的区间大小的情况。

#include <stdio.h>

struct{
int l,r;//分别记录左右两边开始的最大连续区间大小
}node[200000];

int stk[50000],top,n,m;

void build(int idx,int s,int e)
{
    node[idx].l=node[idx].r=e-s+1;

    if(s!=e)
    {
        int mid=(s+e)>>1;

        build(idx<<1,s,mid);
        build(idx<<1|1,mid+1,e);
    }
}

void update(int idx,int s,int e,int pos,int val)
{
    if(s==e) node[idx].l=node[idx].r=val;//val为0代表摧毁村庄,为1代表修复村庄
    else
    {
        int mid=(s+e)>>1;

        if(pos<=mid) update(idx<<1,s,mid,pos,val);
        else update(idx<<1|1,mid+1,e,pos,val);

        if(node[idx<<1].l==mid-s+1) node[idx].l=mid-s+1+node[idx<<1|1].l;//左子树满了
        else node[idx].l=node[idx<<1].l;

        if(node[idx<<1|1].r==e-mid) node[idx].r=e-mid+node[idx<<1].r;//右子树满了
        else node[idx].r=node[idx<<1|1].r;
    }
}

int query(int idx,int s,int e,int pos)
{
    if(s==e) return 0;//如果到了叶子节点就肯定为0

    int mid=(s+e)>>1;

    if(pos<=mid)
    {
        if(pos>=mid-node[idx<<1].r+1) return node[idx<<1].r+node[idx<<1|1].l;//如果被包含在左子树的右区间还要加上右子树的左区间
        else return query(idx<<1,s,mid,pos);
    }
    else
    {
        if(pos<=mid+node[idx<<1|1].l) return node[idx<<1|1].l+node[idx<<1].r;//如果被包含在右子树的左区间还要加上左子树的右区间
        else return query(idx<<1|1,mid+1,e,pos);
    }
}

int main()
{
    int t;
    char s[5];

    while(~scanf("%d%d",&n,&m))
    {
        build(1,1,n);

        top=0;

        while(m--)
        {
            scanf("%s",s);

            if(s[0]=='D')
            {
                scanf("%d",&t);

                stk[top++]=t;

                update(1,1,n,t,0);
            }
            else if(s[0]=='R')
            {
                update(1,1,n,stk[--top],1);
            }
            else
            {
                scanf("%d",&t);

                printf("%d\n",query(1,1,n,t));
            }
        }
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值