POJ-1475-Pushing Boxes(BFS)

Description

Imagine you are standing inside a two-dimensional maze composed of square cells which may or may not be filled with rock. You can move north, south, east or west one cell at a step. These moves are called walks. 
One of the empty cells contains a box which can be moved to an adjacent free cell by standing next to the box and then moving in the direction of the box. Such a move is called a push. The box cannot be moved in any other way than by pushing, which means that if you push it into a corner you can never get it out of the corner again. 

One of the empty cells is marked as the target cell. Your job is to bring the box to the target cell by a sequence of walks and pushes. As the box is very heavy, you would like to minimize the number of pushes. Can you write a program that will work out the best such sequence? 

Input

The input contains the descriptions of several mazes. Each maze description starts with a line containing two integers r and c (both <= 20) representing the number of rows and columns of the maze. 

Following this are r lines each containing c characters. Each character describes one cell of the maze. A cell full of rock is indicated by a `#' and an empty cell is represented by a `.'. Your starting position is symbolized by `S', the starting position of the box by `B' and the target cell by `T'. 

Input is terminated by two zeroes for r and c. 

Output

For each maze in the input, first print the number of the maze, as shown in the sample output. Then, if it is impossible to bring the box to the target cell, print ``Impossible.''. 

Otherwise, output a sequence that minimizes the number of pushes. If there is more than one such sequence, choose the one that minimizes the number of total moves (walks and pushes). If there is still more than one such sequence, any one is acceptable. 

Print the sequence as a string of the characters N, S, E, W, n, s, e and w where uppercase letters stand for pushes, lowercase letters stand for walks and the different letters stand for the directions north, south, east and west. 

Output a single blank line after each test case. 

Sample Input

1 7
SB....T
1 7
SB..#.T
7 11
###########
#T##......#
#.#.#..####
#....B....#
#.######..#
#.....S...#
###########
8 4
....
.##.
.#..
.#..
.#.B
.##S
....
###T
0 0

Sample Output

Maze #1
EEEEE

Maze #2
Impossible.

Maze #3
eennwwWWWWeeeeeesswwwwwwwnNN

Maze #4
swwwnnnnnneeesssSSS


思路:用一个四维数组分别记录箱子和人的位置,son数组记录上一个节点,用优先队列让推的次数最小的先出队,递归输出路径。


#include <cstdio>
#include <queue>
using namespace std;

struct S{
int x,y,bx,by,id,pcnt,acnt;
friend bool operator<(struct S a,struct S b);
}t;

bool operator<(struct S a,struct S b)
{
    if(a.pcnt!=b.pcnt) return a.pcnt>b.pcnt;
    else return a.acnt>b.acnt;
}

priority_queue<struct S>que;

char mp[20][21];
bool vis[20][20][20][20];
int nxt[4][2]={{0,1},{1,0},{0,-1},{-1,0}},val[1000000],son[1000000],idx;

void dfs(int x)
{
    if(son[x]!=-1)
    {
        dfs(son[x]);
        printf("%c",val[x]);
    }
}

int main()
{
    int n,m,i,j,p,q,ex,ey,casenum=1;

    while(~scanf("%d%d",&n,&m) && n)
    {
        printf("Maze #%d\n",casenum++);

        for(i=0;i<n;i++) scanf("%s",mp[i]);

        for(i=0;i<n;i++) for(j=0;j<m;j++) for(p=0;p<n;p++) for(q=0;q<m;q++) vis[i][j][p][q]=0;

        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(mp[i][j]=='S') mp[i][j]='.',t.x=i,t.y=j;
                if(mp[i][j]=='B') mp[i][j]='.',t.bx=i,t.by=j;
                if(mp[i][j]=='T') mp[i][j]='.',ex=i,ey=j;
            }
        }

        vis[t.x][t.y][t.bx][t.by]=1;

        idx=1;

        t.id=0;
        son[0]=-1;
        t.pcnt=0;
        t.acnt=0;

        while(!que.empty()) que.pop();

        que.push(t);

        while(!que.empty())
        {
            t=que.top();

            if(t.bx==ex && t.by==ey)
            {
                dfs(t.id);
                printf("\n");

                break;
            }

            for(i=0;i<4;i++)
            {
                t.x+=nxt[i][0];
                t.y+=nxt[i][1];

                if(t.x>=0 && t.x<n && t.y>=0 && t.y<m && mp[t.x][t.y]=='.')
                {
                    if(t.x==t.bx && t.y==t.by)//推箱子
                    {
                        t.bx+=nxt[i][0];
                        t.by+=nxt[i][1];

                        if(t.bx>=0 && t.bx<n && t.by>=0 && t.by<m && mp[t.bx][t.by]=='.')
                        {
                            if(!vis[t.x][t.y][t.bx][t.by])
                            {
                                vis[t.x][t.y][t.bx][t.by]=1;

                                int oldid=t.id;

                                son[idx]=t.id;
                                t.id=idx;
                                t.pcnt++;
                                t.acnt++;

                                if(i==0) val[idx]='E';
                                if(i==1) val[idx]='S';
                                if(i==2) val[idx]='W';
                                if(i==3) val[idx]='N';

                                que.push(t);

                                t.pcnt--;
                                t.acnt--;
                                idx++;

                                t.id=oldid;
                            }
                        }

                        t.bx-=nxt[i][0];
                        t.by-=nxt[i][1];
                    }
                    else//不推箱子
                    {
                        if(!vis[t.x][t.y][t.bx][t.by])
                        {
                            vis[t.x][t.y][t.bx][t.by]=1;

                            int oldid=t.id;

                            son[idx]=t.id;
                            t.id=idx;
                            t.acnt++;

                            if(i==0) val[idx]='e';
                            if(i==1) val[idx]='s';
                            if(i==2) val[idx]='w';
                            if(i==3) val[idx]='n';

                            que.push(t);

                            t.acnt--;
                            idx++;

                            t.id=oldid;
                        }
                    }
                }

                t.x-=nxt[i][0];
                t.y-=nxt[i][1];
            }

            que.pop();
        }

        if(que.empty()) printf("Impossible.\n");

        printf("\n");
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值