升级ruby版本

安装 Redis 接口时,提示 ruby 版本过低

1、安装

gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3

\curl -sSL https://get.rvm.io | bash -s stable

修改rvm的ruby安装源

[root@localhost ~]# echo "ruby_url=https://cache.ruby-china.org/pub/ruby" > ~/.rvm/user/db

使rvm配置文件生效

source /usr/local/rvm/scripts/rvm

查看rvm中管理的所有ruby版本

rvm list known 

选择一个版本进行安装

rvm install 2.3.4 

使用

rvm use 2.3.4

移除

 rvm remove 2.0.0 

检查版本

ruby --version

没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试

关闭