6114 Problem A Course List for Student (25)

389 篇文章 1 订阅
144 篇文章 2 订阅

问题 A: Course List for Student (25)
时间限制: 1 Sec 内存限制: 32 MB
献花: 97 解决: 32
[献花][花圈][TK题库]
题目描述
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
输入
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
输出
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
样例输入
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
样例输出
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

注意点:

  • 不能使用map映射string到set集合,会超内存
  • 字符串的格式是固定的,因此可以写一个hash规则将字符串转换为整形进行映射,时间复杂度为O(len),len为字符串长度
#define _CRT_SECURE_NO_WARNINGS
#include <unordered_map>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <string>
#include <queue>
#include <stack>
#include <set>
#include <map>

using namespace std;

const int MaxN = 180000;  // 最大('Z' - 'A') * 26 * 26 * 10 + ('Z' - 'A') * 26 * 10 + ('Z' - 'A') * 10 + '9' - '0';
vector<short> List[MaxN];

int StrToInt(char a[])
{
    return (a[0] - 'A') * 26 * 26 * 10 + (a[1] - 'A') * 26 * 10 + (a[2] - 'A') * 10 + a[3] - '0';
}

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG

    int N,K,cn,id,idx;
    char name[5];
    scanf("%d %d", &N,&K);
    while (K--)
    {
        scanf("%d %d", &id, &cn);
        while (cn--)
        {
            scanf("%s", name);
            idx = StrToInt(name);
            List[idx].push_back(id);
        }
    }

    while (N--)
    {
        scanf("%s", name);
        idx = StrToInt(name);
        printf("%s %d", name, List[idx].size());
        sort(List[idx].begin(), List[idx].end());
        for (int i = 0; i < List[idx].size(); ++i)
            printf(" %d", List[idx][i]);
        if (N)
            printf("\n");
    }

    return 0;
}
/**************************************************************
    Problem: 6114
    User: Sharwen
    Language: C++
    Result: 升仙
    Time:441 ms
    Memory:11084 kb
****************************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值