1131. Subway Map (30)

389 篇文章 1 订阅
140 篇文章 0 订阅

1131. Subway Map (30)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.
这里写图片描述
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (< =100), the number of subway lines. Then N lines follow, with the i-th (i = 1, …, N) line describes the i-th subway line in the format:
M S[1] S[2] … S[M]
where M (<= 100) is the number of stops, and S[i]’s (i = 1, … M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order – that is, the train travels between S[i] and S[i+1] (i = 1, …, M-1) without any stop.
Note: It is possible to have loops, but not self-loop (no train starts from S and stops at S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called “transfer stations”), no station can be the conjunction of more than 5 lines.
After the description of the subway, another positive integer K (<= 10) is given. Then K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.
The following figure shows the sample map.
这里写图片描述
Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.
Output Specification:
For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:
Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
……
where Xi’s are the line numbers and Si’s are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.
If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.
Sample Input:
4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001
Sample Output:
2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <string>
#include <vector>
#include <queue>
#include <map>

using namespace std;
const int MaxN = 10000;
vector<int> G[MaxN];
const int INF = INT32_MAX;
char Line[MaxN][MaxN];
vector<int>pre[MaxN];
vector<int>tmpp, path;
int des[MaxN], tranfer = INF;

void SFPA(int st) {

    for (int i = 0; i < MaxN;++i)pre[i].clear();
    bool isInq[MaxN];
    memset(isInq, 0, MaxN);
    fill(des, des + MaxN, INF);
    queue<int>que; que.push(st); des[st] = 0;
    while (que.size()) {
        int u = que.front(); que.pop(); isInq[u] = false;
        for (int i = 0; i < G[u].size(); ++i) {
            int v = G[u][i];
            if (des[v] > des[u] + 1) {
                des[v] = des[u] + 1;
                pre[v].clear();
                pre[v].push_back(u);
                if (!isInq[v]) {
                    isInq[v] = true;
                    que.push(v);
                }
            }
            else if (des[v] == des[u] + 1) pre[v].push_back(u);

        }
    }
}

void DFS(int st,int v) {
    tmpp.push_back(v);
    if (st == v) {
        int oldline = Line[tmpp[tmpp.size() - 1]][tmpp[tmpp.size() - 2]];
        int u = tmpp[tmpp.size() - 2] ,trans = 0;
        for (int i = tmpp.size() - 3; i >= 0; --i) {
            int ln = Line[u][tmpp[i]];
            if (oldline != ln) {
                ++trans;
                oldline = ln;
            }
            u = tmpp[i];
        }

        if (trans < tranfer) {
            tranfer = trans;
            path = tmpp;
        }
    }

    for (int i = 0; i < pre[v].size(); ++i)DFS(st, pre[v][i]);
    tmpp.pop_back();
}

void printPath() {
    reverse(path.begin(), path.end());
    int preline = Line[path[0]][path[1]], pretrans = path[0];
    cout << "Take Line#" << preline << " from ";
    cout << setw(4) << setfill('0') << pretrans;
    for (int i = 1; i < path.size(); ++i) {
        int line = Line[path[i - 1]][path[i]];
        if (line != preline) {
            cout << " to ";
            cout << setw(4) << setfill('0') << path[i - 1] << ".\n";
            pretrans = path[i - 1];
            preline = line;
            cout << "Take Line#" << preline << " from ";
            cout << setw(4) << setfill('0') << pretrans;
        }
    }

    cout << " to ";
    cout << setw(4) << setfill('0') << path[path.size() - 1] << ".\n";
}

int main() {
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG

    std::ios::sync_with_stdio(false);
    int lineN; cin >> lineN;
    for (int i = 1; i <= lineN; ++i) {
        int sn, u, v; cin >> sn >> u;
        for (int k = 1; k < sn; ++k) {
            cin >> v;
            G[u].push_back(v);
            G[v].push_back(u);
            Line[u][v] = Line[v][u] = i;
            u = v;
        }
    }

    int Q; cin >> Q;
    for (int i = 0; i < Q; ++i) {
        int u, v; path.clear(); tranfer = INF;
        cin >> u >> v;
        SFPA(u);
        cout << des[v] << endl;
        DFS(u, v);
        printPath();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值