1081. 检查密码 (15)

389 篇文章 1 订阅
72 篇文章 0 订阅

1081. 检查密码 (15)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 8000 B
判题程序 Standard 作者 CHEN, Yue

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点”.”,还必须既有字母也有数字。
输入格式:
输入第一行给出一个正整数 N(<=100),随后 N 行,每行给出一个用户设置的密码,为不超过80个字符的非空字符串,以回车结束。
输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
如果密码合法,输出“Your password is wan mei.”;
如果密码太短,不论合法与否,都输出“Your password is tai duan le.”;
如果密码长度合法,但存在不合法字符,则输出“Your password is tai luan le.”;
如果密码长度合法,但只有字母没有数字,则输出“Your password needs shu zi.”;
如果密码长度合法,但只有数字没有字母,则输出“Your password needs zi mu.”。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

可能的坑点,一行当中存在空格,不能用cin >> string的方式,用getline一次输入一行即可

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

int main() {
#ifdef _DEBUG
    freopen("data.txt", "r", stdin);
#endif // _DEBUG

    string psw;
    int n; cin >> n; cin.get();
    while (n--) {
        getline(cin, psw);
        bool dig = false, Char = false, dot = false, other = false;
        for (size_t i = 0; i < psw.size(); ++i) {
            if (isdigit(psw[i]))dig = true;
            else if (isalpha(psw[i]))Char = true;
            else if ('.' == psw[i]) dot = true;
            else other = true;
        }

        if (psw.size() < 6) cout << "Your password is tai duan le.\n";
        else if (!other) {
            if (dig && Char) cout << "Your password is wan mei.\n";
            else if (!dig && Char) cout << "Your password needs shu zi.\n";
            else if (!Char && dig) cout << "Your password needs zi mu.\n";
        }
        else cout << "Your password is tai luan le.\n";

    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值