next_permutation

HDU 1027
先排顺,然后直接用next_permutation排序

Ignatius and the Princess II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15329 Accepted Submission(s): 8803
Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, “I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too.” Ignatius says confidently, “OK, at last, I will save the Princess.”
“Now I will show you the first problem.” feng5166 says, “Given a sequence of number 1 to N, we define that 1,2,3…N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it’s easy to see the second smallest sequence is 1,2,3…N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It’s easy, isn’t is? Hahahahaha…”
Can you help Ignatius to solve this problem?
Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub’s demand. The input is terminated by the end of file.
Output
For each test case, you only have to output the sequence satisfied the BEelzebub’s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
Sample Input
6 4
11 8
Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

int main()
{
    int n,m,a[1001],s=0;

    while(cin>>n>>m)
    {
        s=0;
        for(int i=0;i<n;i++)
        a[i]=i+1;
        do
        {
            s++;
            if(s==m)break;
        }while(next_permutation(a,a+n));
        for(int i=0;i<n;i++)
        {
            if(i)printf(" %d",a[i]);
            else printf("%d",a[i]);
        }
        printf("\n");
    }
    return 0;
}

还写了一道也是next_permutation
HDU1716
这道和上一道多了一些格式控制

排列2
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19188 Accepted Submission(s): 6260
Problem Description
Ray又对数字的列产生了兴趣:
现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。
Input
每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。
Output
对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
每组输出数据间空一行,最后一组数据后面没有空行。
Sample Input
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0
Sample Output
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cctype>
#include<iterator>
#include<stack>
using namespace std;

int a[4],b[21];//全局变量
int main()
{
    int n,m,k=0;

    while(cin>>a[0]>>a[1]>>a[2]>>a[3])
    {
        if(a[0]==0&&a[1]==0&&a[2]==0&&a[3]==0)break;

        if(k++)cout<<endl;
        memset(b,0,sizeof(b));
        sort(a,a+4);
        int s=0;

        do
        {
            if(a[0]==0)continue;
            int v1=a[0],v2=a[1],v3=a[2],v4=a[3];
            b[s]=v1*1000+v2*100+v3*10+v4;
            //cout<<b[s-1]<<endl;
            //cout<<a[0]<<a[1]<<a[2]<<a[3]<<endl;
            s++;
        }
        while(next_permutation(a,a+4));
        for(int i=0;i<s-1;i++)
        {
            cout<<b[i];
            if((b[i+1]/1000)==(b[i]/1000))cout<<' ';
            else cout<<endl;
        }
        cout<<b[s-1]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值