细数Qt开发的各种坑(欢迎围观)

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/feiyangqingyun/article/details/53688892

1:Qt的版本多到你数都数不清,多到你开始怀疑人生。从4.6开始到5.8,从MSVC编译器到MINGW编译器,从32位到64位,从Windows到Linux到MAC。MSVC版本还必须安装对应的VS2005 VS2008 VS2010 VS2013 VS2015,MINGW版本必须安装不小于某个版本号的Mingw编译器。很多人一看官网的下载链接,就蒙圈了,到底应该选择哪一个进行下载开发呢。本人就在四块硬盘上安装了七八个操作系统安装了十几个Qt开发环境。 

2:Qt各种乱码问题(不只是Qt的问题,这是IT界的问题,什么utf-8带BOM,什么MSVC默认是GBK编码,什么回车换行符\r\n),困扰Qter一生,有时候解决了界面乱码,输出又出乱码了,解决了输出乱码,界面又乱码了,打印也乱码,显示的那些火星文他妈的谁懂啊,坑爹坑死你。 

3:Qt4到Qt5版本的巨大改动,让很多Qt4时代的代码不能正常在Qt5环境中编译,导致网上各种初学者下载到的Qt4代码编译没有一个通过的人丧失信心,甚至又开始怀疑人生,网上都是骗人的又一次浮现脑海。 

4:为了能够做到开发跨平台应用,不得不安装几块硬盘,安装七八个操作系统,虚拟机的坑使得必须安装真机环境才能测试出真实效果,最基本的你必须安装windows XP,WIN7 32位 64位,WIN8,WIN8.1 WIN10 32位 64位,ubuntu 14.04 15.04 16.04,S3C6410 335 A8 A9各种交叉编译环境,还得单独安装一个干净的XP或者WIN7用于开发android(本人试过N次,在原有的安装了很多东西的电脑上搭建Qt android开发环境死活不成功,必须全新安装的操作系统才可以,所以单独搞了一块硬盘用来Qt开发android)。 

5:Qt发布也困扰了不少的初学者,尤其是高达几十兆的运行库文件,更是崩溃至极,不是提示缺少某个文件,就是那边少了数据库插件,甚至蹦蹦蹦的弹框,最可恨可气无奈的是,明明某些电脑可以正常运行,某些电脑死活跑不成功。 

6:Qt内置方法的变动,让一些喜欢追逐新版本Qt开发环境的Qter们抓耳挠腮,一下子toAscii,一下子就没了,一下子QSound在QtGUI,一下子移到了multimedia中,打印也是,其他的就不细数了。高版本开发环境居然不兼容低版本,这可是犯了大忌啊。 

7:QML兼容性巨坑,各种的不稳定,直到5.7版本开始才好点,很多老式电脑无法正常运行,那个QML设计器更是惨不忍睹无法直视,字体细小难看,还必须放大镜才能看清是什么,既然做了就做好点,不然怎么让开发者用呢,QML开发的商业产品或者作品,到现在也没有看到几个好的,移动端的更加稀少。没有看到一个让人惊艳的作品。 

8:浏览器内核变来变去,以前webkit好好的,后面居然抛弃了,我勒个去,始乱终弃啊!你让以前依赖webkit内核的项目怎么换啊,改来改去的。

展开阅读全文

没有更多推荐了,返回首页