POJ 1007 DNA Sorting

POJ 1007 DNA Sorting

Description

One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC”, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequenceZWQM” has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', frommost sorted” to “least sorted”. All the strings are of the same length.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output
Output the list of input strings, arranged from most sorted'' toleast sorted”. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

解析:题目大致的意思是出现一个字符串,由A,C,T,G四个字母重复排列组成,要你计算逆序数,然后按逆序数大小来输出输入的字符串。由于字符串跟逆序数两个绑定在一起,所以建议用结构体,再用sort排序就OK了。

代码如下:

#include<iostream>
#include<algorithm>
#include<string>
#include<cstdio>
#include<cstring>
using namespace std;
struct str             //要用结构体绑定
{
    char d[120];
    int sum;
}s[120];

int q(str a,str b)    //结构体绑定排序
{
    if(a.sum==b.sum) 
      return 1;
    else 
      return a.sum<b.sum;
}

int main()
{
    int m,n;
    while(cin>>m>>n)
    {
      for(int i=0;i<n;i++)
      {
          cin>>s[i].d;
          s[i].sum=0;
          for(int j=0;s[i].d[j]!='\0';j++)
          {
              for(int l=j+1;s[i].d[l]!='\0';l++)
                if(s[i].d[j]>s[i].d[l])
                  s[i].sum++;             //计算个数
          }
      }
      sort(s,s+n,q);     //sort排序
      for(int i=0;i<n;i++)
        cout<<s[i].d<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值