打开Android Studio报错“Error running ***: Please select Android SDK”

今天打开Android Studio编译项目正常,但在执行Run app的时候莫名其妙弹出配置对话框,一看SDK配置没什么问题,就直接单击“Run”按钮,谁料下面的消息窗口直接提示运行错误“Error running ***: Please select Android SDK”,错误截图见下:


可是Android Studio之前都运行好好的,就在昨天也一直正常编译和运行,为啥今天一打开就无法运行应用了呢?百思不得其解,结果还是在stackoverflow上面找到了问题原因。说是由于Android Studio异常关闭,使得某些配置文件损坏,因此需要在线更新SDK才能恢复被损坏的文件。解决办法如下:
首先依次选择主菜单“File”——“Settings”,菜单路径如下图所示:


上述菜单操作打开设置窗口,然后依次展开“Appearance & Behavior”——“System Settings”——“Android SDK”,在右边的设置界面编辑SDK的路径。如下图所示,单击SDK目录输入框右边的“Edit”链接(红框标注):


单击“Edit”链接之后打开SDK的设置界面如下图所示,这里SDK的目录保持不动,单击页面下方的“Next”按钮,在下一个页面继续单击“Next”按钮,等待Android Studio下载最新的编译工具,我这边是下载了最新的27.0.2版的build-tools。下载完成后单击页面右下角的“Finish”按钮完成更新操作。


回到Android Studio的主界面,此时会自动同步编译工具并重新编译,等待重编完成,即可正常执行Run app的操作了。

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页