解决了个JDK(Java Development Kit,Java开发工具包)配置的问题
问题的描述
运行的应用需要下载安装一个1.3版本的JRE(Java  Runtime Enviroment,Java运行环境)。安装了该JRE后,jdk的版本变为1.3。而eclipse3.1要求的最低jdk版本是1.4。这样的话eclipse就跑不了。
 
问题的原因
安装了JRE1.3后将java.exe、javaw.exe等文件拷贝到了C:/WINNT/system32.运行java时,载入的JDK为通过系统变量Path的路径%SystemRoot%/system32载入的,也就是通过C:/WINNT/system32载入的。这样的话,载入的jdk版本为安装JRE1.3后的1.3。
 
问题的解决办法
在系统变量Path(桌面——我的电脑-属性-高级-环境变量-系统变量)一开始增加这些内容:"C:/jdk1.5.0_06/bin;"(不包括引号)。C:/jdk1.5.0_06为启用jdk的路径。
 
问题的总结
JDK的一般配置方法如下:
用户变量(桌面——我的电脑-属性-高级-环境变量-用户变量)中增加参数:path,值为"C:/jdk1.5.0_06/bin"()。
系统变量(桌面——我的电脑-属性-高级-环境变量-系统变量)中增加参数:classpath,值为".;C:/jdk1.5.0_06/lib/tools.jar;C:/jdk1.5.0_06/lib/dt.jar;C:/jdk1.5.0_06/bin;"(不包括引号)。
C:/jdk1.5.0_06为启用jdk的路径。
测试JDK是否安装正确的方法如下:
将以下内容保存为文件HelloWorld.java。
public class HelloWorld {
  public static void main(String[] args) {
    // Display "Hello World!"
    System.out.println("Hello World!");
  }
}
推荐的保存路径为D:
通过cmd命令行依次输入以下命令后,若显示Hello World则表示安装正确。
d:
javac HelloWorld.java
java HelloWorld
阅读更多
想对作者说点什么? 我来说一句

开发工具包jdk1.7.0

2009年09月13日 53.64MB 下载

没有更多推荐了,返回首页

不良信息举报

解决了个JDK(Java Development Kit,Java开发工具包)配置的问题

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭