vue 解决ie11兼容问题

一、ie11打开vue2.0项目空白,控制台报错 vuex requires a Promise polyfill in this browser
Promise为ES6语法,有的浏览器不支持ES6,所以需要安装babel-polyfill来将ES6转换为浏览器可识别的ES5语法
npm install --save-dev babel-polyfill
②在main.js中引入 import "babel-polyfill"
③在build文件夹中webpack.base.conf.js
//entry: {
// app: ‘./src/main.js’
// },
替换为
entry: {
app: [‘babel-polyfill’, ‘./src/main.js’]
},

二、ie11打不开vue项目,报错 “对象不支持“addEventListener”属性或方法
在index.html中head标签中加上
< meta http-equiv=“X-UA-Compatible” content=“IE=EDGE”/>
这个属性主要是设置浏览器优先使用什么模式来渲染页面的。#代码IE=edge告诉IE使用最新的引擎渲染网页

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页