poj 1007DNA Sorting——冒泡排序

DNA Sorting
Description

One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC’’, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequenceZWQM’’ has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', frommost sorted’’ to ``least sorted’’. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from most sorted'' toleast sorted’’. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

题意: 给定DNA序列,按照DNA序列的逆序对从少到多进行排列,如果两DNA序列的逆序对一样多,则按照输入时的顺序进行输出。

题解: 计算每个DNA序列的逆序对,然后根据这些逆序对进行冒泡排序。

c++ AC 代码

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

int m, n;
char str[105][105], ch[105], s[105];
int length1,length2;
int a[105];

int main()
{
	int tmp;
	cin >> m >> n;
	for (int i = 0; i < n; i++)
	{
		int cnt = 0;
		cin >> str[i];
		// 计算逆序对的数量
		for(int j=0;j<m;j++)
			for(int k=0;k<j;k++)
			{
				if(str[i][j] < str[i][k])
					cnt++;
			}
		a[i] = cnt;
	}
	// 冒泡排序
	for(int i=0;i<n;i++)
		for(int j=0;j<n-i-1;j++)
			if(a[j] > a[j+1])
			{
				tmp = a[j];
				a[j] = a[j+1];
				a[j+1] = tmp;
				strcpy(ch,str[j]);
				strcpy(str[j],str[j+1]);
				strcpy(str[j+1],ch);
			}
	
	for(int i=0;i<n;i++)
		puts(str[i]);
	// system("pause");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值