HDU 1058 Humble Numbers

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12242    Accepted Submission(s): 5353


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 


//题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1058
//解题思路: num = 2^a * 3^b * 5^c * 7^d
//直接遍历暴力破解算出来  最后再排个序就OK了
//不过被坑了好久  用pow算整数的幂次方  精度实在不敢恭维  以后切记切记  最好自己写一个整数的幂次方
//此题还有一个坑 就是"序数词“的表示  num % 11  num % 12  num % 13  都是th


#include<cstdio>
#include<cmath>
#include<vector>
#include<algorithm>
#include<iterator>
using namespace std;
const __int64 MAX = 2000000000;

__int64 cpow(int a, int b)  //自己写一个pow函数 不然会被精度坑死的!!!
{
	__int64 ans = 1;
	int i ,j;
	for(i = 1; i <= b; i++)
	   ans *= a;
	return ans;
}

int main ()
{
    vector<__int64>ans;
    ans.push_back(0);
    __int64 num_2 = 1, num_3 = 1, num_5 = 1, num_7 = 1;
    int  a,b,c,d;
    for(a = 0; a <= 31; a++)
    {
        num_2 = (__int64)cpow(2,a);
        for(b = 0; b <= 20; b++)
            {
                num_3 = (__int64)cpow(3,b);
                if(num_2 * num_3 > MAX)  break;
                for(c = 0; c <= 15; c++)
                {
                    num_5 = (__int64)cpow(5,c);
                    if(num_2 * num_3 *num_5 > MAX)  break;
                    for(d = 0; d <= 12; d++)
                    {
                       num_7 = (__int64)cpow(7,d);
                       if(num_2 * num_3 * num_5 *num_7 > MAX)  break;
                       else     ans.push_back(num_2 * num_3 * num_5 *num_7);
                    }
                }
        }
    }
    
    sort(ans.begin(), ans.end());
    int n;
    while(scanf("%d", &n) && n)
    {
        __int64 num = ans[n];
        if(n % 100 == 11 || n % 100 == 12 || n % 100 == 13)  
                              printf("The %dth humble number is %I64d.\n",n,num);
        else if(n % 10 == 1)  printf("The %dst humble number is %I64d.\n",n,num);
        else if(n % 10 == 2)  printf("The %dnd humble number is %I64d.\n",n,num);
        else if(n % 10 == 3)  printf("The %drd humble number is %I64d.\n",n,num);
        else                  printf("The %dth humble number is %I64d.\n",n,num);

 
    }
    return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值