HDU 1757 A Simple Math Problem

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1681    Accepted Submission(s): 945


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104
 
链接:http://acm.hdu.edu.cn/showproblem.php?pid=1757

解题思路:要使 f0 f1 f2 f3 f4 f5 f6 f7 f8 f9  
                  变成 f1 f2 f3 f4 f5 f6 f7 f8 f9 f10  
                  并且满足   f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
                  就要构建一个矩阵:
                      

/*                                                               0 0 0 0 0 0 0 0 0 a9
                                                                  1 0 0 0 0 0 0 0 0 a8
                                                                  0 1 0 0 0 0 0 0 0 a7
                                                                  0 0 1 0 0 0 0 0 0 a6
        (f0 f1 f2 f3 f4 f5 f6 f7 f8 f9)        *           0 0 0 1 0 0 0 0 0 a5
                                                                  0 0 0 0 1 0 0 0 0 a4
                                                                  0 0 0 0 0 1 0 0 0 a3
                                                                  0 0 0 0 0 0 1 0 0 a2
                                                                  0 0 0 0 0 0 0 1 0 a1
                                                                  0 0 0 0 0 0 0 0 1 a0

要构造一个后面的10*10的矩阵,记为a[][],那最后的结果就是 (f0 f1 f2...f8 f9) * a^(k-9) ,得到一个1*10的矩阵, 第一行的最后一个数就是所求

 */


#include<cstdio>
#include<cstring>
int k, m;

typedef struct matrix
{
	int s[15][15];
};
matrix a,D;
int f[15];
void init()
{
	//初始化a数组;
	memset(a.s, 0, sizeof(a.s));
    for(int i = 9; i >= 0; i--)
		scanf("%d", &a.s[i][9]);
	for(int i = 1; i <= 9; i++)
		a.s[i][i-1] = 1;
	memset(D.s, 0, sizeof(D.s));
	for(int i = 0; i <= 9; i++)
		D.s[i][i] = 1;

	//初始化f数组
    for(int i = 0; i <= 9; i++)
		f[i] = i;
}

matrix mul(matrix A, matrix B)
{
	matrix s;
	for(int i = 0; i <= 9; i++)
		for(int j = 0; j <= 9; j++)
		{
			s.s[i][j] = 0;
			for(int k = 0; k <= 9; k++)
				s.s[i][j] = (s.s[i][j] + A.s[i][k] * B.s[k][j]) % m;
		}
   return s;
}

matrix pow(matrix A, int k)
{
	matrix s = D;
	while(k)
	{
		if(k & 1) 
			s = mul(A,s);
		k = k / 2;
		A = mul(A,A);
	}
	return s;
}
int main ()
{
	while(scanf("%d %d", &k, &m)!=EOF)
	{
        init();      //初始化
		a = pow(a, k - 9);
		long long ans = 0;
		for(int i = 0 ; i <= 9; i++)
			ans = (ans + f[i]*a.s[i][9]) % m;
		printf("%lld\n", ans);
	}
	return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值