HDU 1536 S-Nim

S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3178    Accepted Submission(s): 1406


Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.
 

Sample Input
  
  
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
 

Sample Output
  
  
LWW WWL
 

Source
 

Recommend
LL

最基础的运用SG函数

贴两份代码仅供参考

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int sg[11000],k,st[110],vis[110];
void getsg()
{     
	int i,j;  
	sg[0]=0;   
	for(i=1;i<=10000;i++)
	{       
		memset(vis,0,sizeof(vis)); 
		for(j=0;j<k;j++)
		{   
			if(i < st[j])break;

			if(sg[i-st[j]]<101)   
			vis[sg[i-st[j]]]=1;
			
		}       
		for(j=0;;j++) 
			if(!vis[j]) 
				break;   
		sg[i]=j;   
	}
}
int main()
{    
	int m,n,i,v,sum;   
	while(scanf("%d",&k),k)
	{       
		for(i=0;i<k;i++) 
			scanf("%d",&st[i]); 
		sort(st,st+k);        
		scanf("%d",&m);        
		getsg();        
		while(m--)
		{         
			sum=0;       
			scanf("%d",&n);   
			for(i=0;i<n;i++)
			{              
				scanf("%d",&v);
				sum^=sg[v];     
			}          
			putchar(sum?'W':'L');   
		}       
		putchar('\n');  
	}    
	return 0;
}


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<string>
#include <algorithm>
using namespace std;
#define N 10010
int s[N];
int GS[N];

int gs(int x, int k)
{
	int mex[101];
	memset(mex,0,sizeof(mex));
	if(GS[x] != -1)  return GS[x];
	if(x - s[0] < 0)  return GS[x] = 0;

	for(int i = 0; i < k && x-s[i] >= 0; i++)
		mex[gs(x-s[i], k)] = 1;

	for(int i = 0;;i++)
		if(!mex[i])
			return GS[x] = i;
}
int main ()
{
	int k, i, j;
	int T, n, a;
	while(scanf("%d", &k),k)
	{
		memset(GS,-1,sizeof(GS));
		GS[0] = 0;
		for(i = 0; i < k; i++)
			scanf("%d", &s[i]);    //可移动石子的个数
	
		sort(s,s+k);
		string ans;
		scanf("%d", &T);
		while(T--)
		{
			int temp = 0;
			scanf("%d", &n);
			for(i = 0; i < n; i++)
			{
				scanf("%d", &a);
				temp ^= gs(a,k);
			}

			if(!temp)  ans += "L";
			else	   ans += "W";
		}
	   cout << ans << endl; 
	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值