cuda9.1安装tensorflow问题

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/flowrush/article/details/87295163

报错  libcublas.so.9.0: cannot open shared object file

解决办法:

cuda9.1版本太高,目前最新的tensorflow1.7是在cuda9.0下编译的,官方还没有支持cuda9.1。
下载别人编译的支持cuda9.1的tensorflow文件安装。
https://github.com/mind/wheels/releases/tag/tf1.6-gpu-cuda91
安装whl文件:

因为我的Python 版本是2.7的,所以选择第一个,第二个第三分别对应Python3.5与3.6

安装过程如下

验证 tensorflow步骤

$ python 
>>> import tensorflow as tf
>>> hello = tf.constant('Hello, TensorFlow!') 
>>> sess = tf.Session() #在该步会显示电脑的显卡信息 
>>> print(sess.run(hello)) Hello, TensorFlow! 
>>> a = tf.constant(10) 
>>> b = tf.constant(10) 
>>> print(sess.run(a + b)) 20 
>>>

展开阅读全文

没有更多推荐了,返回首页