hdu3364 Lanterns (高斯消元)

Lanterns

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/65536K (Java/Other)
Total Submission(s) : 10 Accepted Submission(s) : 8
Problem Description
Alice has received a beautiful present from Bob. The present contains n lanterns and m switches. Each switch controls some lanterns and pushing the switch will change the state of all lanterns it controls from off to on or from on to off. A lantern may be controlled by many switches. At the beginning, all the lanterns are off.

Alice wants to change the state of the lanterns to some specific configurations and she knows that pushing a switch more than once is pointless. Help Alice to find out the number of ways she can achieve the goal. Two ways are different if and only if the sets (including the empty set) of the switches been pushed are different.

Input
The first line contains an integer T (T<=5) indicating the number of test cases.
The first line of each test case contains an integer n (1<=n<=50) and m (1<=m<=50).
Then m lines follow. Each line contains an integer k (k<=n) indicating the number of lanterns this switch controls.
Then k integers follow between 1 and n inclusive indicating the lantern controlled by this switch.
The next line contains an integer Q (1<=Q<=1000) represent the number of queries of this test case.
Q lines follows. Each line contains n integers and the i-th integer indicating that the state (1 for on and 0 for off) of the i-th lantern of this query.

Output
For each test case, print the case number in the first line. Then output one line containing the answer for each query.
Please follow the format of the sample output.

Sample Input
  
  
2 3 2 2 1 2 2 1 3 2 0 1 1 1 1 1 3 3 0 0 0 2 0 0 0 1 0 0

Sample Output
  
  
Case 1: 1 0 Case 2: 8 0

Source
“光庭杯”第五届华中北区程序设计邀请赛 暨 WHU第八届程序设计竞赛

题意:n盏灯,m个开关,每个开关控制一些灯。给出n个灯的状态,询问开关的方案数,使得达到给出的状态。

灯的状态是由控制它的所有开关的状态异或而来,所以每个开关不是0,就是1。

高斯消元后,等式左边系数全为0,等式右边系数不为0,显然无解。否则答案就是2^(自由元的个数)。



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

bool ctr[55][55],fuc[55][55];
int equ,var;

__int64 Guass()
{
    int row=0,col=0;
    for( int i,j; row<equ && col<var; row++,col++ )
    {
        for(i=row;i<equ;i++)
            if(fuc[i][col]) break;

        if(i==equ)
        {
            row--;
            continue;
        }

        if(i!=row)
        {
            for(j=col;j<=var;j++)
                swap(fuc[row][j],fuc[i][j]);
        }

        for(i=row+1;i<equ;i++)
        {
            if(fuc[i][col])
            {
                for(j=col;j<=var;j++)//异或消元
                    fuc[i][j]^=fuc[row][j];
            }
        }

    }

    for(int i=row;i<equ;i++)
        if(fuc[i][var])
            return 0;
    return 1LL << (var-row);//解为 2^(m-row)
}
int main()
{
    int cas,k,m,tmp,Q;
    scanf("%d",&cas);
    for(k=1;k<=cas;k++)
    {
        printf("Case %d:\n",k);
        scanf("%d%d",&equ,&var);
        memset(ctr,0,sizeof(ctr));
        for(int i=0;i<var;i++)
        {
            scanf("%d",&m);
            while(m--)
            {
                scanf("%d",&tmp);
                ctr[tmp-1][i]=1;
            }
        }
        scanf("%d",&Q);
        while(Q--)
        {
            for(int i=0;i<equ;i++)
                scanf("%d",&fuc[i][var]);

            for(int i=0;i<equ;i++)
            {
                for(int j=0;j<var;j++)
                    fuc[i][j]=ctr[i][j];
            }
            printf("%I64d\n",Guass());
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值