POJ-2689 Prime Distance

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input
Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output
For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.
Sample Input
2 17
14 17
Sample Output
2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

区间素数筛

#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>

#define MAX 1000010

using namespace std;

typedef long long LL;

bool is_prime[MAX];
bool is_prime_small[MAX];

// 先对小区间筛一遍
void segment_sieve_small() {
    for( LL i = 2; i < MAX; i++ ) is_prime_small[i] = true;
    for( LL i = 2; i * i < MAX; i++ ) {
        if( is_prime_small[i] ) {
            for( LL j = 2 * i; j < MAX; j += i )
                is_prime_small[j] = false;
        }
    }
}

// 对大区间进行筛法
void segment_sieve( LL a, LL b ) {
    for( LL i = 0; i < b - a; i++ ) is_prime[i] = true;
    if( 1 - a >= 0 ) is_prime[1 - a] = false;   // 特殊情况,1不是质数
    for( LL i = 2; i * i < b; i++ ) {
        if( is_prime_small[i] ) {
            for( LL j = max( 2LL, ( a + i - 1 ) / i ) * i; j < b; j += i )
                is_prime[j - a] = false;
        }
    }
}

int main() {
    segment_sieve_small();
    LL a, b;

    while( scanf( "%lld%lld", &a, &b ) != EOF ) {
        b = b + 1;
        segment_sieve( a, b );
        vector<LL> vec;
        for( LL i = a; i < b; i++ ) {
            if( is_prime[i - a] ) {
                vec.push_back( i );
            }
        }

        LL len = vec.size();
        if( len < 2 ) {
            printf( "There are no adjacent primes.\n" );
            continue;
        }
        LL Max = 0;
        LL Min = 0x3fffffff;
        LL MaxLeft, MaxRight;
        LL MinLeft, MinRight;
        for( LL i = 0; i < len - 1; i++ ) {
            if( vec[i + 1] - vec[i] < Min ) {
                Min = vec[i + 1] - vec[i];
                MinLeft = vec[i];
                MinRight = vec[i + 1];
            }
            if( vec[i + 1] - vec[i] > Max ) {
                Max = vec[i + 1] - vec[i];
                MaxLeft = vec[i];
                MaxRight = vec[i + 1];
            }
        }
        printf( "%lld,%lld are closest, %lld,%lld are most distant.\n", MinLeft, MinRight, MaxLeft, MaxRight );
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值