POJ-2449 Remmarguts' Date

"Good man never makes girls wait or breaks an appointment!" said the mandarin duck father. Softly touching his little ducks' head, he told them a story. 

"Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One day their neighboring country sent them Princess Uyuw on a diplomatic mission." 

"Erenow, the princess sent Remmarguts a letter, informing him that she would come to the hall and hold commercial talks with UDF if and only if the prince go and meet her via the K-th shortest path. (in fact, Uyuw does not want to come at all)" 

Being interested in the trade development and such a lovely girl, Prince Remmarguts really became enamored. He needs you - the prime minister's help! 

DETAILS: UDF's capital consists of N stations. The hall is numbered S, while the station numbered T denotes prince' current place. M muddy directed sideways connect some of the stations. Remmarguts' path to welcome the princess might include the same station twice or more than twice, even it is the station with number S or T. Different paths with same length will be considered disparate. 
Input
The first line contains two integer numbers N and M (1 <= N <= 1000, 0 <= M <= 100000). Stations are numbered from 1 to N. Each of the following M lines contains three integer numbers A, B and T (1 <= A, B <= N, 1 <= T <= 100). It shows that there is a directed sideway from A-th station to B-th station with time T. 

The last line consists of three integer numbers S, T and K (1 <= S, T <= N, 1 <= K <= 1000).
Output
A single line consisting of a single integer number: the length (time required) to welcome Princess Uyuw using the K-th shortest path. If K-th shortest path does not exist, you should output "-1" (without quotes) instead.
Sample Input
2 2
1 2 5
2 1 4
1 2 2
Sample Output
14

A*算法求第K短路

#include <cstdio>
#include <queue>
#include <algorithm>
#include <vector>
#include <cstring>

#define MAX 1010
#define INF 0x3fffffff

using namespace std;

typedef struct AStart_node {
    bool operator < ( AStart_node a ) const {
        if( a.f == f ) return a.g < g;
        return a.f < f;
    }
    int to;
    int g;
    int f;
} AStart_node;

typedef struct Edge_src {
    Edge_src( int _to, int _w ) {
        to = _to;
        w = _w;
    }
    int to;
    int w;
} Edge_src;

typedef struct Edge_rev {
    Edge_rev( int _to, int _w ) {
        to = _to;
        w = _w;
    }
    int to;
    int w;
} Edge_rev;

vector<Edge_src> MGraph_src[MAX];
vector<Edge_rev> MGraph_rev[MAX];
int dist[MAX];
int visit[MAX];

int n, m;
int start, end, k;

void Dijkstra( int s ) {
    fill( dist, dist + MAX, INF );
    dist[s] = 0;

    for( int i = 1; i <= n; i++ ) {
        int u = -1, Min = INF;
        for( int j = 1; j <= n; j++ ) {
            if( !visit[j] && dist[j] < Min ) {
                u = j;
                Min = dist[j];
            }
        }
        if( u == -1 ) return;
        visit[u] = 1;
        for( int j = 0; j < MGraph_rev[u].size(); j++ ) {
            int v = MGraph_rev[u][j].to;
            if( dist[u] + MGraph_rev[u][j].w < dist[v] ) {
                dist[v] = dist[u] + MGraph_rev[u][j].w;
            }
        }
    }
}

int AStar( int start, int end, int k ) {
    priority_queue<AStart_node> q;
    if( dist[start] == INF ) return -1;
    if( start == end ) k++;     // 不太懂这个,如果起点和终点一样,要额外跑一次咯?
    AStart_node node;
    node.to = start;
    node.g = 0;
    node.f = node.g + dist[start];
    q.push( node );

    int cnt = 0;
    while( !q.empty() ) {
        node = q.top();
        q.pop();
        // 找到一条最短路径
        if( node.to == end ) {
            cnt++;
        }
        // 找到第k短路
        if( cnt == k ) return node.g;
        for( int i = 0; i < MGraph_src[node.to].size(); i++ ) {
            int v = MGraph_src[node.to][i].to;
            AStart_node newNode;
            newNode.to = v;
            newNode.g = node.g + MGraph_src[node.to][i].w;
            newNode.f = newNode.g + dist[v];
            q.push( newNode );
        }
    }

    return -1;
}

void init() {
    for( int i = 0; i < MAX; i++ ) { MGraph_src[i].clear(); MGraph_rev[i].clear(); }
    memset( visit, 0, sizeof( visit ) );
    memset( dist, 0, sizeof( dist ) );
}

int main() {
    while( scanf( "%d%d", &n, &m ) != EOF ) {
        init();
        int a, b, w;
        for( int i = 0; i < m; i++ ) {
            scanf( "%d%d%d", &a, &b, &w );
            MGraph_src[a].push_back( Edge_src( b, w ) );    // 构造原图
            MGraph_rev[b].push_back( Edge_rev( a, w ) );    // 构造反向图
        }
        scanf( "%d%d%d", &start, &end, &k );
        Dijkstra( end );

        int ans = AStar( start, end, k );
        printf( "%d\n", ans );
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值