PAT甲级 1001 A+B Format

PAT甲级 1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
思路一

分析:本题是从字符串的末尾开始计数,当计数为3且当前字符并不为首字符且首字符并不是负号时,打印逗号。故采用传统的计数比较困难,因为需要从末尾开始进行,但最后需要正序输出,故必须采用堆栈的形式存储。

#include <cstdio>
#include <cstdlib>
#include <string>
#include <stack>
using namespace std;
int main()
{
    int a, b;
    scanf("%d %d", &a, &b);
    string s = to_string(a + b);
    int len = s.length();
    int count = 0;
    stack<int> st;
    for (int i = len - 1; i >= 0; i--)
    {
        st.push(s[i]);
        count++;
        if (count == 3 && i == 1 && s[0] == '-')
        {
            continue;
        }
        if (count == 3 && i == 0)
        {
            continue;
        }
        if(count == 3)
        {
            st.push(',');
            count = 0;
        }
    }
    while (st.size())
    {
        printf("%c", st.top());
        st.pop();
    }
    return 0;
}
思路二

分析:将a+b的和转化为字符串,便于存储,除了当前下标对应的内容不为符号时,且当且下标满足len - (i + 1)) % 3 == 0 && i != len - 1时,打印逗号。

#include <cstdio>
#include <cstdlib>
#include <string>
int main()
{
    int a, b;
    scanf("%d %d", &a, &b);
    string s = to_string(a + b); // 加a+b转化为字母串,正序保存
    int len = s.length();
    for (int i = 0; i < len; i++)
    {
        printf("%c", s[i]);
        if (s[i] == '-')
        {
            continue;
        }
        //len-(i+1)%3==0,表示总长度减去当前坐标到起始点的长度是3的倍数时
        //i != len -1 ,表示当前字母是字符串的最后一个字母时,并不打印逗号
        if ((len - (i + 1)) % 3 == 0 && i != len - 1)
        {
            printf(",");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值