Find The Multiple POJ1426

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

一种DFS一种BFS,但是BFS过不了(超时),当然BFS可以不用队列,用循环代替。

//#include <iostream>
//#include<stdio.h>
//typedef long long int ll;
//using namespace std;
//int n,flag=0;
//void dfs(ll x,int k)
//{
//    if(k>19||flag==1)return ;
//    if(x%n==0)
//    {
//        flag=1;
//        printf("%lld\n",x);
//        return ;
//    }
//    dfs(x*10,k+1);
//    dfs(x*10+1,k+1);
//}
//int main()
//{
//    while(scanf("%d",&n)&&n)
//    {
//        flag=0;
//        dfs(1,1);
//    }
//    return 0;
//}

#include <iostream>
#include<stdio.h>
#include<queue>
typedef long long int ll;
using namespace std;
int n;
int main()
{
     while(scanf("%d",&n)&&n)
    {
        long long k=1;
        //long long m=1;
        queue<long long>q;
        q.push(1);
        while(q.size())
        {
            k=q.front();
            q.pop();
            if(k%n==0)
            {
                printf("%lld\n",k);break;
            }
            //m=m*10;
            q.push(k*10);
            q.push(k*10+1);
        }
    }
    return 0;
}

 

另外一种用数组存储,每次存两个,一个是*10一个是*10+1的,堆上去。

#include <iostream>
#include<stdio.h>
#include<queue>
typedef long long int ll;
using namespace std;
long long m[1000000];
int n;
int main()
{
     while(scanf("%d",&n)&&n)
    {
        for(int i=1;;i++)
        {
            m[i]=m[i/2]*10+i%2;
            if(m[i]%n==0)
            {
                printf("%lld\n",m[i]);
                break;
            }

        }
    }
}

详情可以见https://blog.csdn.net/codeswarrior/article/details/78386313

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值