ubuntu安装wine小结 wine : 依赖: wine1.6错误

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/fr555wlj/article/details/78331853

接连几次安装wine都没有成功,这次要志在必得.
查看可用的wine版本
apt-cache policy winehq-devel
我使用的版本是Ubuntu16.04,百度上的搜索结果真的是一点都不负责任,大多数是添加一个源:

  sudo add-apt-repository ppa:wine/wine-builds
  结果是显示:
 !!! PLEASE NOTE THAT THIS REPOSITORY IS DEPRECATED !!!

For more information, please see:

    https://www.winehq.org/pipermail/wine-devel/2017-March/117104.html

The following commands can be used to add the new repository:

    wget https://dl.winehq.org/wine-builds/Release.key
    sudo apt-key add Release.key
    sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'

表明这个源已经不能使用了,现在获取源的网址是:

sudo add-apt-repository  https://dl.winehq.org/wine-builds/ubuntu

./configure –enable-win64
有一个依赖未被满足

下列软件包有未满足的依赖关系:
 wine-stable : 依赖: wine-stable-i386 (= 2.0.3~xenial)
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

但是,使用apt安装的时候却没有这个的源,这就是问题所在

wulongjian@wulongjian-Inspiron-5557:~$ sudo apt install wine-sta
wine-stable          wine-stable-dev      wine-staging-compat
wine-stable-amd64    wine-staging         wine-staging-dbg
wine-stable-dbg      wine-staging-amd64   wine-staging-dev

接着又有更多依赖

wine-stable-i386:i386 : 依赖: libglu1-mesa:i386 但是它将不会被安装 或
                                 libglu1:i386
                         依赖: libgphoto2-6:i386 (>= 2.5.9) 但是它将不会被安装
                         依赖: libgphoto2-port12:i386 (>= 2.5.9) 但是它将不会被安装
                         依赖: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) 但是它将不会被安装
                         依赖: libgstreamer1.0-0:i386 (>= 1.4.0) 但是它将不会被安装
                         依赖: libudev1:i386 (>= 183) 但是它将不会被安装
                         推荐: libsane:i386 (>= 1.0.24) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
展开阅读全文

没有更多推荐了,返回首页