Centos / RHEL下code blocks wxWidgets安装与配置

第一步, #yum install  codeblocks codeblocks-contrib codeblocks-devel

第二步,到官方下载源码包,我下的是wxX11的2.8.10版的。

#./configure --with-x11 --enable-log --enable-debug --enable-unicode

#make && make install

安装完毕!

第三步, #cd /usr/local/include

#ln -s /usr/local/lib/wx/include/x11univ-unicode-debug-2.8/wx/setup.h ./wx/setup.h
#ln -s wx-2.8/wx wx

新建project后在code blocks中设置project>builder options:

在终端运行

# wx-config --cxxflags

将得到的结果

-I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread

贴到Compiler settings >> Other options中.


在终端运行

# wx-config --libs

将得到的结果
-pthread -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu_xml-2.8 -lwx_ba
贴到Linker options >> Other linker options中.

这样你就可以使用wxWidgets了,我的环境的RHEL 5.X, centos也是一样的。

 如果你编译时出现 wx/wxprec.h: No such file or directory”, "wx/setup.h: No such file or directory”,  或者 "No Target! You should use wx-config program for compilation flags!" 之类的错误的话,应该是上面第三步没有做好。

阅读更多
个人分类: C++库
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭