PAT PAT 1023. Have Fun with Numbers (20)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798



题意:给你一个k位的整数,然后将它乘以2,得到结果sum,如果结果sum的组成数字出现的次数和给出的数相同,那么我们就输出Yes,反之,输出No,
然后再把sum输出。
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int main()
{
    char s[30],c[30],d[30];
    int len,i,j,cnt,cnt1[15],cnt2[15],x,flag;
    while(cin>>s)
    {
        len=strlen(s);
        cnt=0;
        for(i=len-1;i>=0;i--)
        {
            x=(s[i]-'0')*2;
            c[i]=x%10+cnt+'0';//把进位后的数组存起来
            cnt=x/10;//进位
        }
        if(cnt==1)//如果在最后一次运算都有进位,那么肯定是错的,因为相同的数字出现了多次
        {
            cout<<"No"<<endl;
            cout<<"1";//因为乘以2,所以进位为1
            for(i=0;i<len;i++)
            {
                cout<<c[i];
            }
            cout<<endl;
            return 0;
        }
            memset(cnt1,0,sizeof(cnt1));
            memset(cnt2,0,sizeof(cnt2));
            for(j=0;j<len;j++)
            {
                cnt1[s[j]-'0']++;//把出现的数字的次数加起来
                cnt2[c[j]-'0']++;
            }
            flag=1;
            for(j=0;j<10;j++)
            {
                if(cnt1[j]!=cnt2[j])//如果两个数组中数字出现的次数不同,那么肯定是错的
                {
                    flag=0;
                    break;
                }
            }
            if(flag)
            {
                cout<<"Yes"<<endl;
            }else{
                cout<<"No"<<endl;
            }
            for(i=0;i<len;i++)
            {
                cout<<c[i];
            }
            cout<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值