eclipse中导入web项目变成java项目解决办法and dynamic web module和对应的TOMCAT 版本

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Fupengyao/article/details/50900300
右键工程,properties-> Project Facets-> 点convert to faceted..连接 -> 把Dynamic Web Moudle勾上
<span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);">比较拙计,随便写一下,明天再深入研</span><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);">究研究。</span><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);">大致因为java的web系统有多种类型,比如静态的和动态的,然后动态的java web project要设置dynamic web module,也就是动态网页模型,他必须要喝对应的服务器搭配好了才能跑,今天看见的问题就是</span><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);">dynamic web module 2.4 </span><wbr style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);"><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);"> 对应Tomcat 5.5</span><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);">dynamic web module 2.5 </span><wbr style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);"><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);"> 对应Tomcat 6.0</span><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);">dynamic web module 3.0 对应Tomcat 7.0</span><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);">更高版本的dynamic web module对与解析更高版本的js有着更高的效率或者是神秘的地方,貌似T7的安全性更高一点,然后</span><span style="word-wrap: normal; word-break: normal; line-height: 21px; color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; background-color: rgb(188, 211, 229);"><strong>Dynamic Web Module 3.0不支持jboss了,没用过jboss,等用到了在看看,补充几点。</strong></span><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);">补充几个:</span><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><span style="word-wrap: normal; word-break: normal; line-height: 21px; color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; background-color: rgb(188, 211, 229);"><span style="word-wrap: normal; word-break: normal; color: rgb(255, 0, 0);"><strong>Tomcat version 5.5 only supports J2EE 1.2, 1.3, 1.4 Web modules</strong></span></span><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><span style="word-wrap: normal; word-break: normal; line-height: 21px; color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; background-color: rgb(188, 211, 229);"><span style="word-wrap: normal; word-break: normal; color: rgb(255, 0, 0);"><strong>Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules</strong></span></span><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><br style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);" /><span style="color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; line-height: 21px; background-color: rgb(188, 211, 229);">要修改此参数只要选中project 点击右键,点击properties点击project facts,在里面勾选或者点击dropdown list去选择version就可以了,至于tomcat只要去阿帕奇的官网下载最新的就可以了,现在的eclipse只有4.0以上的版本,也就是juno版本才支持</span><span style="word-wrap: normal; word-break: normal; line-height: 21px; color: rgb(70, 70, 70); font-family: simsun; font-size: 14px; background-color: rgb(188, 211, 229);"><strong>Dynamic Web Module 3.0的,4.0一下的,连最常用的galileo也只能支持2.5.
更新换代太快了,新(版本)的技术必然伴随着旧的老的(版本)技术的衰退和不兼容,所以现在遇到最多的问题貌似都是在兼容性上,而不是代码的问题了。以后拿到代码之后第一要务就是检查所有包运行环境和服务器等等的相互兼容性了,第二件事才是去做开发了。。。</strong></span>
</wbr></wbr>

没有更多推荐了,返回首页