POJ-1152 An Easy Problem! 解题报告(数论) 是不是N进制数

连接---- An Easy Problem!
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7802 Accepted: 1884

Description

Have you heard the fact "The base of every normal number system is 10" ? Of course, I am not talking about number systems like Stern Brockot Number System. This problem has nothing to do with this fact but may have some similarity.

You will be given an N based integer number R and you are given the guaranty that R is divisible by (N-1). You will have to print the smallest possible value for N. The range for N is 2 <= N <= 62 and the digit symbols for 62 based number is (0..9 and A..Z and a..z). Similarly, the digit symbols for 61 based number system is (0..9 and A..Z and a..y) and so on.

Input

Each line in the input will contain an integer (as defined in mathematics) number of any integer base (2..62). You will have to determine what is the smallest possible base of that number for the given conditions. No invalid number will be given as input. The largest size of the input file will be 32KB.

Output

If number with such condition is not possible output the line "such number is impossible!" For each line of input there will be only a single line of output. The output will always be in decimal number system.

Sample Input

3
5
A

Sample Output

4
6
11

Source

 
 
题目大意:给定一个数,看能否用N(2<=N<=62)进制表示,输出能表示的最大进制。(32bit*1024约30000所以开大点的数组)
 
#include <iostream>
#include<cstring>
using namespace std;
char s[50000];	
int data[200];	
int main()
{
	int i;
	for(i='0';i<='9';i++)
		data[i]=i-'0';
	for(i='A';i<='Z';i++)
		data[i]=i-'A'+10;
	for(i='a';i<='z';i++)
		data[i]=i-'a'+36;//data[ASCII码]=1~62的数字,建立十进制库

	while(cin >> s)	//这个用scanf还“output limit exceeded”了!
	{
		int len=strlen(s);
		int sum=0,max=0,result=0;
		for(int j=len-1;j>=0;j--)
		{	sum+=data[(int)s[j]];//s%(n-1)=(a *n^3 % (n-1) + b *n^2 % (n-1) + c *n % (n-1) + d % (n-1)) % (n-1)
		//再想想,n^k % (n-1)应该等于1,直接去掉,只剩 s %(n-1)= sum % (n-1);
			if(data[(int)s[j]]>max) max=data[(int)s[j]];
		}
		for(i=max+1;i<=62;i++)
			if(sum%(i-1)==0) {result=i;break;}
		if(result==0) printf("such number is impossible!\n");
		else printf("%d\n",result);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值