AndroidStudio,IDE常见错误AndroidStudio(Error:(1, 0) Minimum supported Gradle version is 3.3. Current ver

1.问题复现
项目之前使用的As版本是2.2版本,升级了As到2.3版本后就会出现这个问题
2.原理
As2.2的Gradle版本和As版本一致,而Gradle插件版本为2.14.1,As2.3对应的Gradle插件版本 为3.3
3.解决办法
先查看wrapper.properties下的Gradle插件版本,需要插件版本与Gradle版本一致
有两种形式,升级Gradle插件版本或降低Gradle版本,当然选择升级
第一步:禁用Instant Run,在Settings/Preferneces > Build, Execution, Deployment option > Instant Run 中,取消所有的选中项
第二步:设置wrapper.properties下distributionUrl=https://services.gradle.org/distributions/gradle-3.3-all.zip,开始自动下载或手动下载
第三步:删除project下的build文件夹,Clean项目重新编译,问题解决

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/G_Fish/article/details/72638498
文章标签: as gradle
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭