Number Sequence (啥啥啥思维)

Number Sequence

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
Output
There should be one output line per test case containing the digit located in the position i.
Sample Input
2
8
3
Sample Output
2
2

转载来自http://blog.csdn.net/grit_icpc/article/details/47726471

#include<iostream>
#include<cstdio>
#include<string.h>
#include<string>
#include<cmath>
#include<queue>
#define LL long long
using namespace std;
LL s[100000],a[100000];
LL so(LL x,LL d)
{
    while(d--)
    {
        x/=10;
    }
    return x%10;
}
int main()
{
    LL n,m,i,j,cla;
    a[1]=s[1]=1;
    for(i=2;i<=34000;i++)//先打表
    {
        a[i]=a[i-1]+(LL)log10((double)i)+1;//求得是目前的位数结尾时是在哪一个位置 1到34000的 位数 
        s[i]=s[i-1]+a[i];//求得是目前每一个i总位数结尾是在哪一个位置 
    }
/*  for(i=1;i<=100;i++)
 	printf("%d ",s[i]); 
 	putchar('\n');
	 
   for(i=1;i<=100;i++)
 	printf("%d ",a[i]); 
 	putchar('\n'); */
    scanf("%lld",&cla);
    while(cla--)
    {
        scanf("%lld",&n);
        i=0;
        while(s[i]<n)
            i++;    //找到他是在第几串里面  比如19 在第6串里面 15〉19〉21    
        m=n-s[i-1];// 找到他在那一串里面的位置   19-15=4表示在4位 
        i=0;
        while(m>a[i])
        i++;
        printf("%lld\n",so(i,a[i]-m) );//例如要取出1234的2,那么多余的位数有2位:34。那么用1234 / 100,得到12,再对12取模10,就得到2
    }
    return 0;
}
//比如 79在第12串中 并且她的位置是10那么  求出了它的i是10也就是第十个数 然后求第十个数在第11位 他是11-10=1位 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值