S - Area of a Parallelogram(数学)

A parallelogram is a quadrilateral with two pairs of parallel sides. See the picture below:

Fig: a parallelogram

Now you are given the co ordinates of A, B and C, you have to find the coordinates of D and the area of the parallelogram. The orientation of ABCD should be same as in the picture.


Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing six integers Ax, Ay, Bx, By, Cx, Cy where (Ax, Ay) denotes the coordinate of A, (Bx, By) denotes the coordinate of B and (Cx, Cy) denotes the coordinate of C. Value of any coordinate lies in the range [-1000, 1000]. And you can assume that A, B and C will not be collinear.

Output

For each case, print the case number and three integers where the first two should be the coordinate of D and the third one should be the area of the parallelogram.

Sample Input

3

0 0 10 0 10 10

0 0 10 0 10 -20

-12 -10 21 21 1 40

Sample Output

Case 1: 0 10 100

Case 2: 0 -20 200

Case 3: -32 9 1247

/*
	海伦公式:p=0.5*(s1+s2+s3);
             S=sqrt(p*(p-s1)*(p-s2)*(p-s3));
*/


四边形的顶点命名是标准命名法(从左下点为A(x1,y1)点,顺时针依此为B(x2,y2),C(x3,y3),D(x4,y4));
则AB//DC(向量平行)
所以 x1-x2=x4-x3
则 x4=x3-x2+x1

来自博客http://blog.csdn.net/islittlehappy/article/details/78154849#reply 楼主的回复

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	int ax,ay,bx,by,cx,cy,dx,dy;
	for(int i=1;i<=t;i++)
	{
		scanf("%d %d %d %d %d %d",&ax,&ay,&bx,&by,&cx,&cy);
		dx=cx+ax-bx;
		dy=cy+ay-by; 
		double s1=sqrt((bx-ax)*(bx-ax)+(by-ay)*(by-ay));
		double s2=sqrt((bx-cx)*(bx-cx)+(by-cy)*(by-cy));
		double s3=sqrt((ax-cx)*(ax-cx)+(ay-cy)*(ay-cy));
		double p=0.5*(s1+s2+s3);
		double ans=sqrt(p*(p-s1)*(p-s2)*(p-s3))*2;
		printf("Case %d: %d %d %.0f\n",i,dx,dy,ans);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值