JAVAMAN is visiting Dream City and he sees a yard of gold coin trees. There are n trees in the yard. Let's call them tree 1, tree 2 ...and tree n. At the first day, each tree i has ai coins on it (i=1, 2, 3...n). Surprisingly, each tree i can grow bi new coins each day if it is not cut down. From the first day, JAVAMAN can choose to cut down one tree each day to get all the coins on it. Since he can stay in the Dream City for at most m days, he can cut down at most m trees in all and if he decides not to cut one day, he cannot cut any trees later. (In other words, he can only cut down trees for consecutive m or less days from the first day!)
Given n, m, ai and bi (i=1, 2, 3...n), calculate the maximum number of gold coins JAVAMAN can get.
Input
There are multiple test cases. The first line of input contains an integer T (T <= 200) indicates the number of test cases. Then T test cases follow.
Each test case contains 3 lines: The first line of each test case contains 2 positive integers n and m (0 < m <= n <= 250) separated by a space. The second line of each test case contains n positive integers separated by a space, indicating ai. (0 < ai <= 100, i=1, 2, 3...n) The third line of each test case also contains n positive integers separated by a space, indicating bi. (0 < bi <= 100, i=1, 2, 3...n)
Output
For each test case, output the result in a single line.
Sample Input
2 2 1 10 10 1 1 2 2 8 10 2 3
Sample Output
10 21
Hint s:
Test case 1: JAVAMAN just cut tree 1 to get 10 gold coins at the first day.
Test case 2: JAVAMAN cut tree 1 at the first day and tree 2 at the second day to get 8 + 10 + 3 = 21 gold coins in all.
先将b排序 b相同就k排序 然后01背包 即可;
代码:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<map>
#include<string>
using namespace std;
typedef long long ll;
typedef double db;
const int maxn= 305;
int f[maxn],n,m;
struct node
{
int l,r;
}a[maxn];
bool operator <(const node &a,const node &b)
{
if(a.r==b.r)return a.l>b.l;
else return a.r<b.r; //反正就是按照b的顺序从小到大排序
}
int main()
{
int T;cin>>T;
while(T--)
{
cin>>n>>m;memset(f,0,sizeof(f));
for(int i=0;i<n;i++)scanf("%d",&a[i].l);
for(int i=0;i<n;i++)scanf("%d",&a[i].r);
sort(a,a+n);
/* cout<<"============"<<endl;
for(int i=0;i<n;i++)printf("%d %d\n",a[i].l,a[i].r);
cout<<"============"<<endl;*/
for(int i=0;i<n;i++)
{
for(int j = m;j>0;j--)
{
f[j] = max(f[j], f[j-1]+(j-1)*a[i].r+a[i].l);
}
}
cout<<f[m]<<endl;
}
return 0;
}