Maven Web报错:org.apache.jasper.JasperException: Unable to compile class for JSP

Maven Web报错:org.apache.jasper.JasperException: Unable to compile class for JSP

今天被这个问题弄得,拽下了一大把的头发!哭唧唧~~~

遇到的问题截图:
在这里插入图片描述
于是查找各方面的资料,发现是jar包的冲突,于是乎,修改了pom.xml。
加上了,<scope>provided</scope>
注意加的位置是:<dependency></dependency>里边,这样子的效果是只进行编译,防止jar包之间的冲突。
在这里插入图片描述
多次尝试之后发现还是不对,,,,,再查找资料,发现Maven中的Tomcat是6.0,这个版本的不支持jdk1.8。我…

不慌,加上一个插件,tomcat7…接着来!

在这里插入图片描述
这一次,可以了,终于成了…


另说的一件事情:
也可以同时加上一个jdk1.8的插件
在这里插入图片描述


注意:
在这里插入图片描述
用的是tomcat7:run;
如果继续用tomcat:run还是会使用Maven的Tomcat6;会继续出错…

有什么问题,评论或者联系我的邮箱,gaoxinsuc@163.com,一起学习,一起进步!

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页