poj 2585 Window Pains

Window Pains
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1601 Accepted: 800

Description

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows: 
11..
11..
....
....
.22.
.22.
....
....
..33
..33
....
....
....
44..
44..
....
....
.55.
.55.
....
....
..66
..66
....
....
....
77..
77..
....
....
.88.
.88.
....
....
..99
..99
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window  1 and then window  2 were brought to the foreground, the resulting representation would be:
122?
122?
????
????
If window 4 were then brought to the foreground:
122?
442?
44??
????
. . . and so on . . . 
Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 3 components: 
  1. Start line - A single line: 
    START 

  2. Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space. 
  3. End line - A single line: 
    END 

After the last data set, there will be a single line: 
ENDOFINPUT 

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement: 

THESE WINDOWS ARE CLEAN 

Otherwise, the output will be a single line with the statement: 
THESE WINDOWS ARE BROKEN 

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

覆盖问题,拓扑排序。考虑4*4矩阵,(i,j)点可以被哪些2*2矩阵覆盖,比如(1,1)显然只能被矩阵1覆盖,而(1,2)可以被矩阵1和2覆盖,依次类推,预处理得到(i,j)可被覆盖的矩阵编号。

扫描输入矩阵,当扫描到(i,j)时,当前元素是多少?比如是3,而通过预处理我们知道(i,j)可被2,3,5,6覆盖,那么也就是说3覆盖了2,5,6,这样我们就可以连三条边,3->2,3->5,3->6,当全部扫描完矩阵后,整幅有向图被建立起来。之后只要利用拓扑排序判断是否有环即可。有环说明电脑坏了。因为比如3->2->4->3,3覆盖了2,2覆盖了4,也就是3覆盖了4(传递性),而4->3表明4覆盖了3,这样既存在3覆盖4,又存在4覆盖3,显然不可能,也就是不满足无环有向图的反自反性。

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;

vector<int> maz[4][4];
int adj[10][10],indeg[10],mat[4][4];
char s[20];
void init(){
    for(int i=0;i<3;i++)
        for(int j=0;j<3;j++){
            int t=3*i+j+1;
            maz[i][j].push_back(t);
            maz[i][j+1].push_back(t);
            maz[i+1][j].push_back(t);
            maz[i+1][j+1].push_back(t);
        }
}
bool topo_sort(){
    int top=0,cnt=0;
    for(int i=1;i<=9;i++)
        if(!indeg[i]) indeg[i]=top,top=i;
    while(top){
        int j=top;
        cnt++;
        top=indeg[top];
        for(int i=1;i<=9;i++)
            if(adj[j][i]&&!(indeg[i]-=adj[j][i])) indeg[i]=top,top=i;
    }
    if(cnt==9) return false;
    return true;
}
int main()
{
    init();
    while(scanf("%s",s),s[0]=='S'){
        memset(adj,0,sizeof adj);
        memset(indeg,0,sizeof indeg);
        for(int i=0;i<4;i++)
            for(int j=0;j<4;j++){
                scanf("%d",&mat[i][j]);
                for(int k=0;k<maz[i][j].size();k++)
                    if(maz[i][j][k]!=mat[i][j]){
                        indeg[maz[i][j][k]]++;
                        adj[mat[i][j]][maz[i][j][k]]++;
                    }
            }
        scanf("%s",s);
        if(topo_sort()) puts("THESE WINDOWS ARE BROKEN");
        else puts("THESE WINDOWS ARE CLEAN");
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值