Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. This is an example of one of her creations:
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).
For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious. So now she asks you to write a program that does the job for her!
Input
The input file will contain one or more test cases.
Each test case consists of one line containing two strings ‘preord’ and ‘inord’, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters.
(Thus they are not longer than 26 characters.) Input is terminated by end of file.
Output
For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG BCAD CBAD
Sample Output
ACBFGED
CDAB
题意:
给你了二叉树的先序遍历和中序遍历,让你写出这个二叉树的后序遍历。
preorder(先序遍历):先根再左后右(DLR)
inorder(中序遍历):先左再根后右(LDR)
postorder(后续遍历):先左再右后根(LRD)
代码如下:
#include <iostream>
#include <string>
#include <queue>
#include <cstring>
using namespace std;
const int N=1000+100;
char sa[N],sb[N];
int ls,num=1;
void dfs(int be,int ed,int father);
void hxbl(int ch);
struct node
{
int left,right;
}tree[N];
int main()
{
while(cin>>sa+1>>sb+1)
{
num=1;
memset(tree,0,sizeof(sb));
ls=strlen(sb+1);
dfs(1,ls,0);
hxbl(sa[1]);
cout<<"\n";
}
}
void dfs(int be,int ed,int father)
{
if(num==ls+1)
return;
for(int i=be;i<=ed;i++)
{
if(sa[num]==sb[i])
{
num++;
if(!tree[father].left)
tree[father].left=sb[i];
else
tree[father].right=sb[i];
dfs(be,i-1,sb[i]);
dfs(i+1,ed,sb[i]);
}
}
}
void hxbl(int ch)
{
if(ch)
{
hxbl(tree[ch].left);
hxbl(tree[ch].right);
cout<<char(ch);
}
}