The Moronic Cowmpouter poj3191(负进制转换以及其他进制转换模板)


The Moronic Cowmpouter
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4078 Accepted: 2111

Description

Inexperienced in the digital arts, the cows tried to build a calculating engine (yes, it's a cowmpouter) using binary numbers (base 2) but instead built one based on base negative 2! They were quite pleased since numbers expressed in base −2 do not have a sign bit. 

You know number bases have place values that start at 1 (base to the 0 power) and proceed right-to-left to base^1, base^2, and so on. In base −2, the place values are 1, −2, 4, −8, 16, −32, ... (reading from right to left). Thus, counting from 1 goes like this: 1, 110, 111, 100, 101, 11010, 11011, 11000, 11001, and so on. 

Eerily, negative numbers are also represented with 1's and 0's but no sign. Consider counting from −1 downward: 11, 10, 1101, 1100, 1111, and so on. 

Please help the cows convert ordinary decimal integers (range -2,000,000,000..2,000,000,000) to their counterpart representation in base −2.

Input

Line 1: A single integer to be converted to base −2

Output

Line 1: A single integer with no leading zeroes that is the input integer converted to base −2. The value 0 is expressed as 0, with exactly one 0.

Sample Input

-13

Sample Output

110111

Hint

Explanation of the sample: 

Reading from right-to-left:
1*1 + 1*-2 + 1*4 + 0*-8 +1*16 + 1*-32 = -13

裸的进制转换t

-2进制转换


#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>

using namespace std;

#define ll long long
#define For(i,a,b) for(i=a;i<=b;i++)
#define _For(i,a,b) for(i=b;i>=a;i--)
const ll inf = 1e5;

ll abs(ll n)
{
    return n>=0?n:-n;
}

ll digit[inf];

void exchange(ll n,ll c)  ///进制转换函数
{ 
    if(n==0)   ///注意特判0
    {
        cout<<0<<endl;
        return ;
    }
    ll i,cnt=0;
    ll num;
    while(n)
    {
        num = n%c;
        cnt++;
        digit[cnt]=abs(num); ///保证每位数都是正数
        n-=abs(num);         ///类比正进制 每次都减去余正数
        n/=c;                ///与正进制相同
    }
    _For(i,1,cnt) cout<<digit[i];  ///倒序打印
    cout<<endl;
}

int main()
{
    ll n;
    ll c = -2;  ///多少进制
    while(cin>>n)
    {
        exchange(n,c);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值